Sync Parallels virtual machines to Amazon cloud

I Have MacOS X 10.11 and use a Parallels (latest release) W7 virtual machine.
I am a oDrive PRO subscriber.
My issue is this: When the .pvm file is uploaded to amazon cloud the virtual machine stops working. The .pvm file seems to be changed in some way that the Parallels app can’t use it anymore.
The Parallels app displays a “Can’t find hdd file” and something about the “ownership” on the file.
I have to restore the file from my Time Machine Backup to use it again.
I have tried many times, I have even deleted the Parallels folder from Amazon cloud and reloading it again… same result.
Is anyone experiencing the same problem?

Trying to sync an ever-changing virtual machine disk image in this way is probably going to create some unexpected/bad behavior. Are you actively using the pvm while it resides in the odrive pro synced folder and odrive is running?

What is possibly happening is that odrive is uploading the file, which is holding an open file descriptor on the pvm file, and preventing other applications from opening it properly. There could also be some strange application-level conflicts as parallels uses the pvm drive and odrive keeps seeing changes to it and tries to upload it.

I strongly recommend against having an active file of this type inside an odrive-monitored folder. It is fine for placing non-active archives/backups. Since odrive is a real-time, active sync engine that constantly monitors for changes it will keep seeing that file change and want to upload those changes. I imagine the upload, itself is going to take a long time, as well.

Hi, Tony!
Yes, the upload takes a loooong time.
But I have tried also to quit odrive before opening the PVM file… same result.
Guess I would have to move the pvm file out of the odrive pro-sync folder and back-it-up manually after each use.
Hope odrive team can find a workaround for this probem in the future.

You can try stopping odrive sync while you work within the pvm, then start sync back up afterward. You can find the option to stop sync in the odrive tray menu.

Once again I tried, once again failed.
After backup in Amazon drive ends, I have paused sync. Same result.
I have even quit the odrive app… same.
The parallels display says "Can’t connect to Drive 0"
“The file is missing, used by another process or you don’t have permission to access it”.
Could the odrive app possibly change the characteristics of some of the content in the .pvm package?
I have seen it is backed up as a directory tree instead of a single package.
Could this be the reason?

This is odd. We don’t change the content of the files. A package file is actually a directory in the filesystem, Finder just displays it as a single file. That is why you see it in its “true” form in the cloud.

Can you try the following experiment when you get a chance?

  1. Take a working pvm package and copy/move it into the odrive directory. Once it is uploaded, move it back to its original location and try opening it. Does it show the same error?


Nope, didn’t work. I used this sequence:
I closed the odrive app. Used the pvm file, no problem.
Move the pvm file to odrive folder, launch the app, it uploaded the file.
Closed the odrive app and open the pvm file: first time worked.
Closed pvm file (to avoid further changes).
Launch odrive app, sync’d again from the odrive folder, (it had to re-sync, since I used it).
Closed the odrive app… Open pvm file… same error!
It looks like it happens not the first time it sync (file uploaded first time), but when it has to re-sync (actual sync with the cloud service).
Hope this information helps to fix the issue.

If you move the non-working pvm to another location on your desktop, does it continue to give the same error?

I will try to get a trial version of parallels and test at some point. in the meantime, we might be able to analyze the structure of the pvm to see if anything changes, other than the size of the files. To do this we can do the following:

  • Open up a terminal
  • cd to the folder that contains a working pvm in odrive
  • ls -alR ./nameofpvm.pvm > working_pvm_structure.txt
  • Run through the sync process that results in the unreadable pvm file
  • ls -alR ./nameofpvm.pvm > non_working_pvm_structure.txt

Attach the two text files here so that we can diff them.

Let me know if you have any questions on the above.

Thanks for the help Tony!

I have tried moving the pvm file outside any odrive folder.
I have even tried and open it with the odrive app off. No luck!

I have included the structure files you ask for. Hope this helps.non_working_pvm_structure.txt (6.4 KB)
working_pvm_structure.txt (6.2 KB)

Thanks again!

PS. I can see in the non-working file in the windows 7-0.hdd folder a file with “” extension. This extension is not in the file before the sync. It looks like the app decided just to live the link, and not the actual file. That could be the origin of this bug, don’t you think?

Yes, that appears to be the issue. More specifically, it detected a conflict and renamed your local .hdd file to a conflict file.

If you right-click on the pvm and select “show package contents”, navigate to where that file is and rename the .cloud file to something like “Windows 7-0.hdd.0.{5fbaabe3-6958-40ff-92a7-860e329aab41}” and then rename the conflict file back to the original name (remove the " (conflict)" part, does it work?

If it does work, can you reproduce the problem again and send a diagnostic? I want to see why it is detecting a conflict.


Still, same error.
As soon as I change the name of the “.cloud” file, the software deleted it.
I changed the name of the “conflict” file and the pvm worked as it should.
I closed the pvm file and let the software to sync during the night.
It created a new .cloud file and rename the hds file with “conflict” in it.
In the Amazon cloud browser I see today the hds file created at 5:37 (the one that worked, I presume), but created again a “conflict file” with the same name at 7:08, wich is still on sync.
It is very frustrating.

Can you submit a diagnostic? I want to see if I can tell why the conflict is being made.

Can you clarify if you are using one machine or two machines? Is the PVM on one machine or is the PVM synchronizing between multiple machines?

I have just send the diagnostic using the odrive app.
My user is (sign via amazon).
(Hope that is what you need).
I could recreate the same error using an old PVM file with WXP in it.

The PVM file is in just one machine. The idea is creating a backup in the cloud.
It is not synchronized between machines.
I have just tested an old PVM file (an old virtual machine with WXP installed in it), and it recreates the same error.

I took a look at the diagnostic and I can see the effects of a general Amazon Cloud Drive problem we’ve been seeing for a while now. ACD will sometimes throw an error on upload, but the file will make it up. This ends up appearing like a new file since we have to rely on the information Amazon is providing us. In your case I am seeing frequent issues with the large file uploads, where errors are occurring during upload. The file may eventually make it, but they could be giving us false information.

I have a couple of recommendations:
With these large hdd files, it is not going to be practical to actively sync with Amazon Cloud Drive in this way, especially if you are frequently using parallels.

If the goal is full backup, then it may be better to create a compressed archive of the pvm on a periodic basis and drop that into cloud drive. I would even recommend breaking up the archive so it is easier to get up. This won’t be as easy as just running the pvm inside odrive, but this has multiple potential issues, including the one you are running in to.

Alternatively, depending on your needs, you could store a base pvm in the cloud (as a pretty much static template file) and then run odrive inside the pvm to sync the content you are creating. I do not know the details of your use case on parallels, but if you are only backing up to protect the user-created content you are making inside the pvm, then I think this would be better suited for that. Even if you needed to restore the entire pvm, it would just be a matter of accessing the content you need via odrive inside the pvm. This has the added benefit of granular visibility and control of your files.

I actually like both!
I will create a “base” PVM file and back it up. Then install odrive inside the virtual machine to backup an specific software I am using in it. That will save a lot of time and bandwidth.
Is it possible to exclude the parallels folder from the sync process since it is included inside the “documents” folder that I am syncing? or…
Is it possible to program odrive to exclude PVM files specifically? or…
Should I have to move the parallels folder to some other location in the drive?

Again, thanks for the effort!

Hi @fhervert,
Apologies for the late reply here. I’ve been meaning to come back to this.

Which way did you end up going here?

Right now you can’t exclude specific files, although you probably already know that.

I am curious how things are working for you, so please update this thread when you get a chance.