Sync doesn't sync

I’m syncing folders to Onedrive, and it appears to be working fine. But when I try to use the unsync feature, to off-load the files from my SSD, I get a warning saying “Some files are not in sync. Do you want to permanently delete these files and unsync? XXX is not in sync.” XXX is some folder within the folder i want to unsync. This happens to about 50% of the folders I have synced to the cloud. Resyncing doesn’t do anything, and all files appears to be synced.

Two questions:

  1. Why does this happen, and what can I do to make it work better?
  2. What happens if I, instead of pressing “Cancel”, choose “Delete and unsync”?

Hi @staffan,

It may be that there are blacklisted items in that folder.
When the dialog pops-up, does it mention a path that is not in sync?

There have been some tweaks to unsync in the last couple of releases. Make sure you are running the latest version of the client, as it may improve the behavior you are seeing.

To update to the latest:

  1. Exit odrive
  2. Download the latest version from here: Set Up Your odrive
  3. Install

With the latest versions, the selected folder will be put into the OS recycle/trash bin and then the folder will be unsynced and turned back into a placeholder.

It mentions a folder, but there are many folders in various places that says they’re not in sync. I synced with Odrive from scratch, and when looking everything seems to be there. No blacklisted files, or files or folders without a blue mark.

I have the latest version installed.

So, it should be safe to delete and unsync?

It’s just that it seems to happen a lot. I used to sync to Amazon Drive, and never saw this, but when syncing to Onedrive it started popping up. Maybe that’s unrelated. I updated Odrive at the same time too, so it could very well be related to the update too.

Hi @staffan,
Can you send a diagnostic from the odrive tray menu and we can take a closer look?

Thanks! I sent the diagnostics report.

Hi @staffan,
Thanks. I am taking a look.

For the example I can see in the logs, can you tell me what files are listed in the STUFF folder that odrive is identifying as having unsynced items, when unsyncing?

Make sure to show any hidden items, too.

There’s just 3 files, none hidden. And it looks identical on the server side.

Hi @staffan,

It could be that there is an item that is marked as read-only.

Try installing this test build, which will make that clear in the sync activity log, if that is what is happening.

To install:

  1. Exit odrive
  2. Download new version from here: odrive
  3. Install

This one just worked. I have tried several folders, without any problems.
Thanks! I sent a diagnostic report too.

1 Like

Great! Thanks @staffan.

We’ll get these changes out into an official build soon.

The test build doesn’t, however, put any of the unsynced files in the trash.

Hey @staffan,
That is expected. It only puts items in the OS trash if it detects that they are “dirty” (haven’t been uploaded).

1 Like