Sync back from Google Drive to Shared Drive

I have a network drive that is setup to sync to Google drive. When I look at the files on google drive, files that are written to drive are appearing from the 3rd party software we use.

When I look at the network drive, they are not showing, indicating they are not being written back from the cloud to the drive. I have the auto download set at always so I am not sure why it’s not downloading.

Any ideas?

Hi @russell2,
Are you seeing the placeholder files, or just no files at all?
If you add a file to the network drive, does it sync to Google Drive?
Can you send a diagnostic from the odrive menu and provide the name of an example file and path that is not showing up?

Hi Tony,

Thanks for the prompt response.

If I add a file to the local network drive, it didn’t sync. The folders that are already there are synced and show the blue check mark. I added the file, test file and nothing happened.

Here is the path to the TEST FILE.txt I added:
R:\Bus Logs - Driving sheets completed\2017

When I right click on the folder, I see the sync/remove sync option indicating the folder is on the sync list.

I sent a diagnostic report through as well.

Russell J Scoates

Hi @russell2,
It looks like the diagnostic didn’t go through. Can you try sending it again?

When you click on the folder, do you see an odrive “refresh” option? If you click on that, does anything change?
Do you see anything listed under waiting or not allowed in the odrive menu?
Are any folders under “sync to odrive” in the odrive menu listed as invalid or not found?

I’ve sent another diagnostic report - I just get a warning saying don’t do unless told too, but no confirmation once I hit submit.

I have the option of refresh and the test file now has the blue check mark on it and synced to google drive. Interestingly, although the folders have the blue check mark, none of the files inside them have, although they are on google drive and the shared drive.

So now the test file I added to the network drive worked, but the files on google drive have still not synced down though.

I added a second test file to the same directory and that successfully synced by itself. I deleted that file from Google Drive and it successfully deleted the test file from the network share, but not the other files I am trying to sync.

I ended up downloading all the files that were not synced, deleting them off google drive and then re-uploaded them, and they have now successfully synced.

I hope that all makes sense!!

Hi @russell2,
The behavior you are describing does seem odd. It sounds like you are in a synced state now, though.

Try this:

  • Right-click on the folder and select “sync”
  • Slide the slider to “Everything” (all the way to the right), check both checkboxes, and then click the big silver sync button. It shouldn’t do much since everything is already in sync, but it will make sure the folder has its rules set now.
  • Now, add a file into that folder on the remote side (from odrive web client or Google Drive web client) and see if it syncs down to your system.

I have done what you suggested and it looks like it is working as designed at this point. I will continue to monitor and if there are any problems, I will get back in touch.

Thanks again for your prompt attention.


1 Like

Great! Thanks for the update @russell2.