Sharing is problematic

Sharing link seems to work in Chrome. However, trying the download in Safari and Firefox with the same URL results in partially downloaded files that do not open.

Do you have a shared link I can test with? I am not able to reproduce this issue with my own data yet.
Are you seeing this only with larger files? If os, how large?


Below is a test link. This one is a bit more than 1GB, but a 300MB file failed in the same way too. See attached picture for the error message I get.

In addition, while my first test seemed to work with Chrome (the 300MB file that precipitated my post), the link below did not work. Trying a few different browsers, and it seems like the file is not entirely downloading - just stopping, leaving a partial non-working file.

Password = 2222

Hi, Just tried this on Safari (v9.1.2) constraining the download to 1MB/sec down and was able to download it properly. Very cool drone footage, btw :slight_smile:

When you have these failed downloads, are you noticing that the file size is less than it should be?
Does the browser indicate it is a failed download, or does it look complete?
How fast are you seeing the download speed, approximately?

Thanks. File size is definitely smaller than it should be, reported in the 300-400MB range depending on which attempt we’re talking about. No error message is shown while downloading, the browser just quietly stops downloading, leaving the partial file on my local drive.

Download is pretty good, in the 85Mb/s range.

Out of 10 attempts, 1 worked, though there does not seem to be a pattern. Downloading the file directly from Google Drive has zero issues.

Hi @JPM,
Can you run a few more tests? Our ops team adjusted a few things on the backend that we think could improve your results.


I think it’s good! Only did 4 tests (2 Chrome 2 Safari) but they all worked without a problem. Download speed was good, about 85 Mb/s.

You can close this ticket/case/whatever. Thanks!

Great to hear! Thanks for the report.