Share Links Failing

So sharing links particularly if I’m putting time frames or passwords on them seem to be failing. I mainly share folders. Not sure if this still applied to individual files.

I check the links straight away and later on and they work on my end sometimes. Other times it says unavailable. But for my clients and myself, some links come back into operation after an hour or so of sending.

Seems to be some sort of bug. Replicated problem with another new user I’ve brought to the system. I can’t access file he sent me with a password.

Hi @anarchyconcepts

Thanks for reporting the problem. I can’t seem to reproduce the problem… I can use shared links to files and folders with passwords and/or expiration times just fine.

What storage are you using? Is there a lot of other activity going on against that account?

Also, would it be possible for you to send us a link to an example of a non-functioning link to help us troubleshoot? (Create a new test folder and share it with us either over direct/personal message on post on the forum if there’s nothing in it you wouldn’t mind being out in the public–that would be preferred, anyway).


See this link sent to me by my colleague.
Password protection no expiration. Hours later and still not working.

Using a few different cloud services with the same problem. Predominately Box and OneDrive accounts playing up.

Hi @anarchyconcepts,
The operations team took a look at this link, and it was actually deleted about 7 hours ago by the owner.

Do you have another example that is listed on the for the link creator?

Yep just had another instance of failure.

Tested soon as created last night. Today at 2PM failed for my client.
"Hi Mate, odrive tells me “The shared link is no longer available.”
I tried it now at 5PM and it is working.
No restrictions applied. Everytime I’m sending a link externally I’m getting this same issue.

Hi @anarchyconcepts,
Thanks for the follow-up. It helped to track down the issue, at least in the last case. The link provided is a OneDrive link and the attempt to access it ends up hitting a session failure. This would be okay, but the error OneDrive returned says that the item no longer exists, instead of the proper exception, so odrive cannot handle it properly, on the spot.

I have raised this as an issue to follow-up with with the integration team (and OneDrive).

My apologies for the inconvenience. If you are using shared links against OneDrive it may be best to use their native sharing, for the time being.

1 Like