Share links are presenting broken files

Lately, several of our team members have been using the “share link” or “copy share link to clipboard” feature when trying to share PDF or PPT files. Every time, the file opens fine, but is broken or contains blank pages, etc. By navigating through odrive and finding the original file, they can open it successfully and it is not broken. This only seems to translate with the “share” feature.

Is there a reason this is happening or perhaps is a universal issue with odrive that just recently started happening?

Hi @miranda,
This is not expected. If you can provide the following info I can investigate:
What storage source you are linked to and sharing from?
What type of file is this?
Can you provide an example?


Hi Tony,

We are using Amazon S3 as our storage source.
The broken files are typically PPT files.
Here is an example:

Here are also a few screen shots when downloading the file via the link above.

However, when we navigate to that file through odrive, the file is fine and NOT corrupt or broken.

For the example, I am able to download and open without any errors from the shared link. Are you seeing issues doing the same on your own system?

Yes, those screen shots were from downloading from my own system. There are several other people who have expressed the same sort of issues when trying to open a ppt file that is “shared.”

Strange. I’ve tried downloading with Chrome and Internet Explorer. I am using Office 2016. After downloading I can open without any errors and everything looks in order (no missing images like your screenshot shows).

Can you tell me what browser is being used?
Do you know if your organization has any network monitoring software that could be affecting the transfer?
Do you have any endpoint protection software or anti-virus running? If so can you try temporarily disabling it to see if it makes a difference?

Hi there,

I personally am using Chrome, but multiple people have had this issue, possibly on different browsers. We are also all using Office365, which auto-updates to the most current version of Office.

We do not have any network monitoring software.

We typically don’t have any endpoint protection software or anti-virus.

I think it’s also important to note that this has not always been an issue. It only seems to have surfaced over the past week or two.

Thanks for the response. I’ve since tested against Office 2011 on OS X and a couple other Windows systems in various locations with the same shared link without ever hitting an error opening the file.

Do you see the same error when downloading from my shared link (i took the downloaded file and uploaded it to my own storage)?

Is it possible for you to test on a system outside of your office? Perhaps a personal computer at home, just to compare?


Hi Tony,

I was able to download your shared link with no issues or errors. I’m also at home on my personal network. Do you think it’s an internet issue? Seems a little odd considering we have really good internet at work…

Can you verify that your own shared link above also shows no errors on your home system?

My guess is that the network at work is good, but there might be something that the traffic is passing through that could be manipulating the stream a bit. I’ve seen this happen before with DLP software acting on the packets, although it would be surprising that it would manifest in this way.