SFTP setup with rsync.net

Hello all,

I am trying to link an SFTP account.

The account is located at rsync.net.

  • They support SFTP access

I was able to make this work by using the user name, host name, and keyfile as credentials.

  • Verified via FileZilla

Using the same setup reports an access error through odrive linking.
Can anyone shed some light on this?

Thank you.

Hi @sturakov ,
Can you try adding the absolute path to your user home folder on that service in the link information?

I believe it should be something like:

Hey Tony! Thanks for the quick response.

I tried your suggestion.

PS C:\Users\aleks> ssh de1160@de1160.rsync.net pwd

I used that for the path, but unfortunately the issue continues.

Hi @sturakov,
Can you take a quick screenshot of the error you are seeing?

I had worked with a user previously on connecting to rsync.net. That user had created a test user for me to use and this was the link information that I used to successfully link and sync:

Name: rsync.net
Type: Internet Accessible SFTP Server
Host: [test username].rsync.net
Start Path: /data1/home/[owner username]/[test username]
Max Concurrent Connections: 3

Thanks, I tried out the starting path with /data1, still error.
I also tried using the password instead, still error.

Here are the screenshots.



Hey @sturakov ,
Thanks for the reply.

My previous test wasn’t with a key pair. It should work fine, but it is hard to say with linking errors. Is there any chance you could get me a test account? If I had an account to test with I should be able to debug the issue pretty quickly.

Thanks for working on this with me Tony.

I don’t mind sharing the main account access with you. Can I send you the information privately somehow?

Hi @sturakov ,

If you are comfortable with it, you can send it to me via a direct message here (click on my name and then click “Message”). I will delete the information once I have it.

Hey Tony,

Just wanted to check in.
How’s it going?

Thank you!

Hey @sturakov ,
I saw your message. Thanks for that!

I am trying to carve out some time for testing and should hopefully get to it in the next day or two. Sorry for the delay.

All good, thank you very much!

1 Like

Marking this as resolved, thanks to Tony’s investigation.

Issue was

  • I was using my account password instead of storage password
  • The path did help
  • When I was testing my storage password, I had to switch between the keyfile form and password form.
    Cleaned out the previous text in keyfile form, used just the password form, and that did it.
1 Like