Right Click Context Menu Delay

Hi all, I’m experiencing an issue where right clicking on file explorer items in Windows 10 takes ages to open the context menu. I’ve isolated the issue to odrive, as disabling the odrive context menus in shellexview instantly restores the right click menus to normal, speedy operation.

I’ve also noticed a behavior that the more items selected when right click is pressed, the longer it takes to open the menu. But still, even one item can take up to 10 seconds.

This has been happening through several iterations of Windows updates. But I have other systems running the same OS version that have no issues with the odrive context menus. Does anyone know of any known driver/software conflicts that could be a potential cause here? It’s a pretty vanilla Windows implementation and I can’t rightly discern what is significantly different between each system.


Hi @zkidwell,
Thanks for reaching out about this.

Is odrive running when you see this issue?

We have a timeout on the Explorer extension to account for latency when accessing external drives, when trying to determine the available actions. This timeout is 2 seconds, but is additive when selecting multiple items.

You should only see this delay if odrive is not running, however, since it is a wait time for the odrive app to respond to the Explorer extension with the list of available actions.

I’ll look at how we can improve this (perhaps something much lower by default, with the option of adding a method to configure a longer timeout).

It actually happens both when odrive is running or after I’ve closed it. The only thing that resolves the issue is to disable the odrive context menus in shellexview. That solution is not a real workaround if I actually want to use odrive.

Of course, I think it is local to this machine, but finding the real source of the issue has eluded me.

After the delay are you still getting the odrive right-click options?

I’ll see about getting you a test build to reduce the timeout we have in place, to at least verify if that is the cause of the delays

Right, after the delays the odrive options do appear in the menu.

Hi @zkidwell,
Here is a build that significantly decreases the timeout. Can you see if this makes a difference in your case? https://www.odrive.com/s/401ba2f1-ab23-49aa-9019-c052bad71d01-60401cfd

Thanks Tony. Will give a try and report back.

It looks like this build might have solved the issue. A small part of me remembers that reinstalling odrive in the past did remedy the situation in the short term, only to have it return. I just want to rule out that possibility with some more use over the next few days. I’ll bump this thread if the problem resurfaces.

But right now I’m a happy camper. I appreciate the fast turn on this. Really fantastic support. Thanks Tony!

1 Like