Question about Sparse files

I read this section of the usage guide and accordingly have set disableSparse": true, in my general conf file and rebooted.


I expected that .cloud files would show as zero bytes but that is not the case:

Have I misinterpreted or done something wrong?

Attached is my conf file and I generated diagnostics at 00:02 Irish time

odrive_user_general_conf.txt (244 Bytes)

Hey @sean,

Were these files already on-disk before you made the change? The change is not retroactive for existing files, so that may explain what you are seeing. If you unsync the containing folder and then expand it again, the files should show 0KB for size.

OK. I tried to unsync and expand again and I got this error:


Hi @sean,
This means Microsoft responded with either a 429 (rate limit) or a 503 (server unavailable) on the list folder request.

I’m not sure what is up with Microsoft, but they have been kind of sucking lately in this department. I reached out to them at the end of last week, but I haven’t heard back yet. I did read some information about the COVID -19 situation putting extra strain on their systems.

Was odrive doing anything else with OD4B at the time, or was this just a one-off request?
Did a retry go through?

The next release has some additional, general, auto-retry logic in it for Microsoft integrations, which will help a bit, especially for background operations.

Its very hit and miss. I managed to finally expand the parent folder but havent been able to expand sub folders yet because of the same error. Guess I just have to keep trying.

Hey @sean,
Can you send a diagnostic when you get a chance? I just want to see what errors they are spitting out.

Also, were the sparse files correctly disabled on the expand?

Diagnostics sent at 09:57 Irish.
Yes, file sizes are now showing as zero thanks.
If I were to hazard a guess it looks like I can expand about 1 folder every 2 minutes.
There are not other processes going on wiht OD4B that I am aware of (no current uploads etc.)
To me it just looks like the act of trying to expand a folder triggers some sort of block for 2 minutes or so on the OD4B side.

1 Like

Just fyi … the reason I wanted to turn off sparse files is that my go-to tool for managing my disk space is “WizTree” and sparse files really mess up its stats :wink:

Looks like I can’t unsync individual sparse files. Is that expected behaviour?

I have a mixture of physical and sparse files in my google drive. I only want to unsync the sparse ones to get them back to zero bytes and don’t want to unsync the ones that are already physically there in my odrive folder.

Hey @sean,
The unsync option won’t appear, unfortunately, because the files are already “unsynced”.

There are a couple of things you can do:

  • You can replace the files with empty files of the same name to remove the sparse files (I know this will be tedious unless you script something up.).
  • You can move the synced files out of odrive, unsync the folder, expand the folder, and then move the files back in, which will replace the placeholders in there.

I know neither option is great…

OK. Thanks @Tony
Let me think about which is easier.

As a feature request, would it be possible in future to have the odrive client do the unsyncing of the sparse files next time it starts when disableSparse is set to true?

1 Like