Problem with Subfolder Sync

Odrive is not synchronizing the subfolders as it should. I thought it was the name of the folders, even changing, did not sync.
I tried reinstalling the software and it did not work either.
How should I proceed?

Hi @diegorigolino,

As per my understanding, changes you are making in local machine or cloud service are not reflecting, did you try “right-click --> refresh (odrive)” option in subfolder.

  • Is there any possibility of odrive syncing files in an other folder / cloud storage but the job is not completed yet (see odrive tray menu)?
  • Are you able to download files in root folder of same storage cloud?
  • Are you able to upload files in root folder of same storage cloud?

Please send diagnostic report from odrive tray menu, mention your OS username, timestamp and folder path / sub-folder name not syncing your contents or changes. I will look into it

Thanks,
Asif

Is there any possibility of odrive syncing files in an other folder / cloud storage but the job is not completed yet (see odrive tray menu)?
odrive is syncing other folder. But this folder called Valquiria is not 100% sync. The subfolders is not syncing.

Are you able to download files in root folder of same storage cloud? Yes
Are you able to upload files in root folder of same storage cloud? Yes

Hi @diegorigolino,
It is possible to hit exceptions while scanning or syncing in certain areas. Those areas will be queued for later, internally, and odrive will move on to other areas of your storage. In your case, there were a few exceptions being hit, including rate limit errors and a couple of filesystem errors that may be trnasitory.

I wouldn’t worry about it unless you have no sync activity and you still have files that have not yet synced. If things are still uploading, then I would recommend just letting odrive continue until it finishes. It will get back to the other folders eventually.

I also don’t get my subfolders synchronised (Mac os 10.12.6), despite choosing sync with the option to synchroise subfolders.

Hi @kris,
Are you talking about syncing down to your local machine or syncing up to the cloud? Can you provide a diagnostic from the odrive menu and give me the path to one of the folders you are seeing an issue with?

Can this have something to do with the fact that I am only using the free version?

Hi @kris,
The free version should always automatically upload any new/changed local files to your remote storage. The free version also allows you to recursively download all of your files from remote to local.

Can you provide some clarification on what you are seeing as per my questions above?

I see the subfolders with a little red line despite the upper folder being marked as green. When I open any of those folders the contents begin to download.

Hi @kris,
If you right-click->sync on a folder, slide the slider all the way to the right for “Everything”, check “include subfolders”, and then click the big silver sync button, does odrive sync the selected folder and its contents?

No. It does not. It shows the top folder as synched but the folders within stay red.

Hi @kris,
Can you perform this action on a folder, making sure to:

  • Slide the slider all the way to the right for “Everything”.
  • Check the “Include subfolders” checkbox
  • Leave the “Save and apply to new files and folders” checkbox unchecked

Once the action is done and sync does not traverse into the subfolders, can you send a diagnostic from the odrive menu?

I actually it started working on its own today. But I get a long list of “Not Allowed” files. Why would that be? I sent the diagnostic report

Hi @kris,
odrive is reporting some filesystem exceptions for some of these files. It looks like your odrive folder is on a secondary volume on your system. Is this an internal or external drive?

Since it looks like you have a lot of activity going on at the moment, I would suggest waiting until things settle, and then see what your “not allowed” queue looks like. If it still have several items, try a restart of odrive to see if it clears.

The Folder for Odrive is on an external USB drive. I have three google accounts and one dropbox account so it is a bit of data to shit. I will wait and see.

Thanks for the update @kris. For now waiting for things to settle is the best way forward. We can see how things shake out once odrive has been able to process everything.

Keep in mind that we don’t officially support having the odrive folder on an external volume because it can create some unexpected side effects. There are folks who operate in this configuration successfully, but it really depends on the use case and environment.

Ok. The reason for having it external is that my Trashcan Mac only has 250Gb SSD drive. I keep all my data on external drives.