Problem with files removed from blacklist

Hi, we use odrive to sync a local windows server folder with Google Drive. We’re using both ways sync (windows > GDrive and Gdrive > Windows) and we have a list of few extensions we’re not used to sync, most of them bigger files (like MP4 videos).

But we decide now to start syncing this type of files. So, we edit the odrive_user_premium_conf.txt configuration to remove this extension (MP4) from the blacklisted extensions…

But I’ve noted that no mp4 files on our windows server synced to Gdrive. I thought we need to sync again, and tried this on the folder level. No success. Then, we decide to right click directly on the mp4 file to sync, but it shows only the option to UNSYNC (but the file is not on Gdrive).

I thought that we need to UNSYNC and then SYNC again. No I have a bigger problem… when I do this, I get an error (“Can’t ynsync file.mp4. Unexpected error. Please try again later.”), after that, the file just DISAPPEAR from the windows server and I can’t locate it anymore (not even on the trashbin).

Any ideas on how can I solve this 2 problems now?

Hi @fatordigital,
This is definitely strange. Sounds like there could be a bug here. We will investigate and get back to you.

Can you send a diagnostic from the odrive menu so that we can take a closer look at things?

Hi @fatordigital,
I’ve done some quick initial testing and odrive is working as expected, so far. Let me describe what’s I’ve done:

1 - Add exe to blackListExtensions

 "blackListExtensions": [

2 - Restart odrive
3 - Add several .exe files in various folders in a Google Drive link (they are ignored by odrive)
4 - Remove .exe from blackListExtensions

 "blackListExtensions": [

5 - Restart odrive

At this point odrive starts syncing the .exe files that were previously ignored.

  • Are these the same as the steps you’ve taken?
  • Can you post your odrive_user_premium_conf.txt so I can see if there is anything else I should be including in my testing?
  • Are you still able to reproduce the same issue? If so, can you send a diagnostic after reproducing?

Hi Tony, thanks for your reply.
Yes, i’ve restarted Odrive AFTER edit the conf file. And restarted again after identify the error. But still have problems.
I’ve just tested again and sent the diagnostics after. I don’t know what is included on this diagnostics, but the file that i’ve tested was Fator_Digital/Temp/animacao 2 (timeline)_4.mp4
After clicked UNSYNC, the file just disappear.

here is my conf txt file:

    "blackListExtensions": [
    "blackListNames": [
    "blackListPrefixes": [
    "forgetEncPassphrase": false, 
    "initialUploadBatchSize": 4, 
    "maxConcurrentDownloads": 8, 
    "maxConcurrentJobs": 8, 
    "maxConcurrentUploads": 16, 
    "maxTransferMBytes": 1024
1 Like

Thanks @fatordigital!

I found one bug in the unsync logic and will provide a test build for you in a bit. This doesn’t solve the main issue you are seeing with these files not being synced after removing them from the blacklist, but it will prevent the file from being unsynced, in this case.

Do these files have a checkmark on them indicating they are synced?
What happens when you copy one of the files and paste it. Does that copied file sync properly?

Hi Tony, yes, they have a checkmark indicating that they are synced. If I copy/paste the file, it creates a copy and sync the copy normally.

Don’t worry about the build to solve the unsync problem. It’s nor urgent. I can wait for a solution to the files not being synced after removed from blacklist. Can you have an ETA for that?

Hi @fatordigital,
Can you give this build a shot?

I wasn’t able to reproduce your exact issue, but I added some additional logic that should hopefully address what you are seeing.

It could take a couple of minutes for the upload to kick-in, so give it a bit after starting and let me know how it goes and if you have any questions.

Hi Tony, I think you solved the problem. At least partially!

  • After install the new version, all the MP4 files that are not synced now DO NOT SHOW the synced icon (ok)

  • When I right click the file, it shows only the UNSYNC option. I’ve clicked, it shows the same error from yesterday, but do not delete the file and then it start to sync all mp4 files on that folder (ok)

But, in other folders, I have to do the same. I need to “unsync” and then sync again. Tried to just “sync” all folders but it not syncs these mp4 files if not unsync at least one of them before.

Thank you for your help!

Tony, an update:
I think the problem is solved. I’ve just made a search on my windows server and discover that the MP4 files are syncing, but we have a few HUGE files (bigger than 2GB) that are first on queue. But looks like that MP4 on others folders are already synced! Thank you!

Hi @fatordigital,
Thanks for the follow-up! I’m glad to hear that all of the files are now uploading. It could take a little while for the syncing to start during the normal initialization and scanning process, but it all should eventually sync up. Just let me know if you run into any more issues.