PRO Sync folder shows "invalid"


Trying out PRO Sync with Amazon Cloud Drive. I’m on OS X, and trying to sync an external USB hard drive.

I right click the folder I want to sync, choose “PRO Sync” and then a web browser opens asking me to choose a destination. I choose a folder inside my Amazon Cloud Drive and click “Okay.”

Everything seems normal at that point, except if I click the oDrive app at the top of the screen, it shows “Open {my folder name} [invalid]”.

When I select that option, it says “Pro Sync folder {my folder name} could not be synced.” “Error accessing folder” and my options are Cancel, Remove from PRO Sync and Change folder location.

And ideas?


Hi cdub!

I have already reported this issue, and it may have been addressed in Mac release 5023 though I did not see mention of it in release notes.

The workaround is to pick “change folder location”, and select the exact same folder location you started with. When I do this the folder opens and syncing begins.

My setup is very similar to yours - OS X, a bunch of external USB drive locations I want to sync with odrive PRO.

Thanks @dougblair, I’ve tried this. But I still get the [invalid] after selecting my folder in “change folder location”.

I’m using v 5031 (if I am to believe the grayed text on the drop-down menu).

Hmmm. I am also on 5031 now, and it just worked correctly for me. Looks like we need to ask the Greater Minds :slight_smile:

One reason a folder can be invalid is if odrive can’t write to it. Is the USB drive writable by odrive?

The other reason a folder can be invalid is if the mapped destination in odrive becomes missing (moved).

Thanks. The drive is FAT which is not writable on OS X. Is there any way to get odrive to do a read-only upload?

I think this bug is still with us. I just tried to map another folder, and [[invalid]] showed up. Fixed as outlined above by changing the folder location to the same location, and sync is proceeding as expected.

Not currently. The drive needs to be writable to sync to. I’ve passed on the idea of allowing sync to read only sources to the product team.

How many pro sync folders do you have now? I am wondering if this is a scaling abberation.

291 folders are PRO synced. I have changed my strategy so that I add one or two, allow them to completely sync (usually overnight) before adding more. Sometimes it results in [invalid] and sometimes not.

permissions on all the USB drives are drwxrwxrwx+ . Pretty sure the + indicates some additional attributes. All are owned by my login and my group.

Tiz a mystery :slight_smile:


I tried a little experiment, with results that lean toward this being a “scaling” issue.

On one Mac Mini there are now 296 folders mapped with odrive PRO. When I attempt to add another (297) it adds, but the sync does not start and the folder location appears as “[invalid]”. After I locate the invalid folder, open it, get the option to change the folder location, choose the original location again, the folder opens and syncing commences as expected.

On a second Mac Mini I mounted the same USB drive from the original machine (all 21 of these are mounted - this happens to be my Plex server :slight_smile: ). On this machine I set up PRO sync on a USB drive folder. Sync started immediately with the correct location. So this appears to work as expected when the host knows about only one (or maybe just a few) PRO locations, but the bug shows up with a larger number. Since I only noticed this a couple weeks back, 255 seems like a number to investigate.

While I have the subject open… every PRO sync’ed folder is a “folder” by definition, so there’s no need to add the word “folder” to it’s name. And with 300 lines in it (6 vertical screenfuls of scrolling) it’s just unwieldy. If this section of the tray menu could be displayed as “open PRO folders -> list of folder names” instead of all of the folders being at the top level of the menu, and the list of names could be sorted, it would look a lot cleaner. Just another $0.02.

Hi, I have the free version on windows 8.1, and have the same problem, I try unnistalling and instaling over again a few times, even with ccleaner, but have no success,:frowning:

Hi @jorgvegar,
Can you tell me what specific error you are receiving? If you can provide a screenshot of the issue along with sending a diagnostic from the odrive tray menu that would be great.


hi, ive just have send the report and this is a screenshot of the problem


Can you click on “Authorized User”->“Deauthorize” and then re-login. That should clear up this issue. I would suggest leaving the odrive folder where it is placed, by default, instead of trying to move it to the Desktop. You can create a shortcut to it on the Desktop, instead.

Hi, i tried this option, but when i restart the software still getting the same problem, i also tried deauthorizing and uninstalling and repairing

Can you send another diagnostic please?

hi, i sent the diagnostic again, i include a screenshot of the deauthorizing opntion my account appera to be disabled

Thanks @jorgvegar,
Let’s try removing the odrive cache folder entirely.

  1. Exit odrive
  2. Rename the C:\Users\Gusano\odrive folder to C:\Users\Gusano\odrive_bak (You can delete this later if you want)
  3. Delete the C:\Users\Gusano.odrive folder (This folder is hidden, so you will need to enable viewing hidden files and folders in Explorer. Also note the period at the beginning of the name)
  4. Restart odrive

Also, can you check how much free space you have available on your C: drive?


Sorry, here is minor correction to the folder path you need to delete in step #3

  1. Delete the C:\Users\Gusano\.odrive folder (This folder is hidden, so you will need to enable viewing hidden files

If you are still run into the same problem, kindly provide requested details:

a) How much free space you have available on your C: drive
b) User permissions in C:\Users\Gusano\odrive folder (e.g. are you able to add any file directly into this folder without hitting any permission error from Windows?)

In tray menu “Open odrive Folder [Invalid]” is only possible when odrive folder is created correctly but having permission issue in writing changes to the folder (a and b can help us to further look into the matter)

Thank you for your patience


1 Like