OSX Sierra folder content randomly does not sync

Hi there,

I have my music database uploaded on an encrypted folder but it randomly only syncs the folder names and not the content. It synced fine on my other computer running Yosemite. I also tried unsyncing and resyncing which worked on the “old” computer but no changes on Sierra.
Any solution to that?

Thanks and best

Hi @martenvonengel,
Are you having trouble uploading or downloading?

Can you send a diagnostic from the odrive tray menu and let me know the path that is having issues?

Hi Tony,

thanks for the reply – I’ve sent the diagnostics (I guess). The path is in Encryptor/… But you cannot see this path as it is encrypted, right?

I can see that there is activity in the folder. Can you describe the issue you are seeing, in detail?

What I need to know is:

  • What actions are you taking?
  • What is the result?
  • What are you expecting?

You metnioned:

but I am unclear if you are adding new content to be uploaded, or you are trying to download the entire library to your Sierra machine.

I have odrive installed on my old computer uploading several Gigs of Data – everything seemed to have worked fine. Now I got a new computer and things are a little different.
I installed Odrive, sync’ed (downloaded) some things I needed and once I restarted, I was asked to resume installing odrive. A bit odd, since I already had done just that. Proceeding I ended up having two odrive folders on my disk and some trouble with sync’ed data. So I uninstalled, erased everything from the computer and started from scratch. I started sync’ing again, some folders with subfolders, some just the first level.
When sync’ing was finished, I noticed that some files where just placeholders which I expected to be downloaded completely and others where just not there at all.

As for my music files (where there are files completely missing), it is structured like that:
All the artists seem to be there but most of the album folders are missing. But then with a few artists, everything is there, subfolders, titles, everything. I tried unsync’ing, refreshing, even deleting – the missing files just don’t pop up.
As I was worried that they might not be on the cloud space, I unsync’ed the files on the old computer, resync’ed and everything popped up from the server as expected.

Another “bug” I noticed on the fly is that I cannot sync or unsync a selection of files – only the first file will be treated. With folders everything works fine.

Hi there

is there no answer to my error? Still the folders do not sync. I can unsync, resync – still only empty folders. If I do the same on a Yosemite run computer, all is well, folders and files as expected.

I’d really appreciate a solution as there is no use of the otherwise amazing tool if I don’t know what is and what is not synced.


Hi @martenvonengel,
My apologies, I missed your reply in this last one. I try to get to everything, but sometimes I can overlook a post.

The issue is certainly odd. There should be no difference in functionality between Yosemite and Sierra. Sierra should actually perform better.

Since you ran into some odd initial install/setup behavior, maybe it is best if we start from scratch and then drill into a specific Encryptor folder that is currently having issues (and only that folder), to see if it still has the same issue. If so we can focus on just that folder to try to get to the bottom of this.

If you don’t have any objections to this, can you follow the instructions here to uninstall:

Then install the latest version from here:

Once that is complete, drill straight into a folder that is giving you trouble, and only that folder. Does it show the content now? If not, please send another diagnostic and we will go from there.


Hi Tony,

no worries, I see how that can be some sort of a hassle at times.
I did all that but unfortunately the problem persists. I’ve sent diagnostics…


Hi @martenvonengel,

Can you take a few screenshots now of this folder and post them here?
One from the view of this folder in Finder on your Sierra computer
One from the view of this folder in the odrive web app (https://www.odrive.com)
One from the view of this folder in Finder on your Yosemite computer.


Hi Tony,

I’ll see what I can do, have to restore the old computer from a backup first.
Can I send you the screenshot on a more private way than post it in the forum?
And I don’t see how I could get to the folder on the web app as it is encrypted and I wouldn’t know which one it is. Or would I?


Hi @martenvonengel,
Ahh, sorry, was late last night when I was writing that. You are correct, you cannot see it on the web currently.

Since this is in Cloud Drive, you can add a file to this folder, wait for it to sync, then go to the Amazon Drive web client and look at the most recent file under “Recent Files”. There is a folder icon next to the files listed that will bring you to the parent folder. You will need to make sure you are not uploading other things, so there isn’t additional noise in the recent files list.

I just want to see how many files are listed there, even though we won’t be able to read the names properly. I also want to validate that a file can be uploaded properly.

Once that is done, please unsync the folder and resync it, to see if you newly uploaded file shows up in the listing, or is missing too.