Osx > s3 > linux unable to sync, you do not have permission

Unable to sync unpack.cloud.  You do not have permission.
odrive Status

Trash (0):

Not allowed (0):

Waiting (0):

Active (0):

Uploads (0):

Downloads (0):

Sync folders (1):
ProSyncFolder - localO2Path:/home/ec2-user/odrive-agent-mount remoteUri:/ status:Active

Recently added to remote (0):

Recent Errors:

06:08:13AM 139653948634880 139654525474560 RAISED apply_local_expand_file([u'cloudO2Path=/home/ec2-user/odrive-agent-mount/<REDACTED>-aws-s3/bin/unpack.cloud', u"remoteAttr=FileAttributes(id=u'/a384b79c-b077-4d9a-b83e-1cca44fbf1c2-597445b9/eyJtb2RUaW1lIjogMTQzNjkwMzI2NywgIm9pZCI6ICJiMmIyMDU2NC05YWM5LTQ1ZWUtOTRiYi0wZTE0YzA5OTM3ODgiLCAiaXNGb2xkZXIiOiBmYWxzZSwgIm5hbWUiOiAidW5wYWNrIiwgInNpemUiOiAxMjQ1fQ==', name=u'unpack', isFolder=False, size=1245, modTime=1436903267, uri=u'/a384b79c-b077-4d9a-b83e-1cca44fbf1c2-597445b9/7e5bf911-8946-47b9-87d7-ebab460a5021/eyJtb2RUaW1lIjogMTQzNjkwMzI2NywgIm9pZCI6ICJiMmIyMDU2NC05YWM5LTQ1ZWUtOTRiYi0wZTE0YzA5OTM3ODgiLCAiaXNGb2xkZXIiOiBmYWxzZSwgIm5hbWUiOiAidW5wYWNrIiwgInNpemUiOiAxMjQ1fQ==', contentTag=None)"]) --> SyncAdapterRequestException(code S3x_NO_PERMISSION caused by S3xRequestException(code S3x_NO_PERMISSION - <?xml version="1.0" encoding="UTF-8"?>
<Error><Code>AccessDenied</Code><Message>Access Denied</Message><RequestId>94B3193AC64C2DE5</RequestId><HostId>JZZXI1UQFqJpbIq8/Dlql4MbA/raZbWi660HfuKBg2vtnlExGg5eUbXhp29igO267AQ32ENH7q8=</HostId></Error>))

temporarily i modified the iam policy to s3* for the bucket as well (not that it had any issues for the client from osx)

Further the unpack.cloudf file shoudn’t have any issues either:

-rwxrwxrwx  1 ec2-user ec2-user    0 Jul 14  2015 unpack.cloud
-rw-rw-r--  1 ec2-user ec2-user    0 Jul 14  2015 unz.cloud

How do i resolve this?

Hi @aaron.caito,
This is definitely an odd one.

Are you only receiving this error on only these two items when syncing?
Are you able to download these items from the odrive web client?
Were these items uploaded via the MacOS client, or are you saying that the MacOS client has not problem syncing them?

Hi Tony,
I receive this error on all my data that is synced (~500 gb)
I receive same error from odrive webclient.
I no longer have permission to sync to the origional macbook earlier.
My premium subscription lapsed for a couple weeks before i turned it back on.

Right now i have no access to my unsync’d data.

Hi @aaron.caito,
Thanks for getting back to me.

A free subscription should be working just fine for this, so I don’t think you need to worry about the lapsed Premium subscription.

The error is being returned from Amazon S3 when odrive is attempting to access the data. We haven’t changed any logic regarding S3 for quite a while. Is it possible that the IAM policy is somehow incorrect, or the credentials are wrong?

Are you able to list any items from the webclient, or does it fail immediately?
What error does the web client give?

A couple other questions:
Are you able to upload anything to the bucket, or is that failing too?
After trying several operations from the MacOS client, can you send a diagnostic from the odrive tray menu so I can take a closer look?

From what you are describing it sounds like odrive is being allowed to list bucket objects but not access them. This usually indicates an object permission/ownership issue.

Hi @aaron.caito,
I wanted to follow-up on this to make sure you were able to get past these issues. Please let me know when you are able to look at the items above and how how else I can assist.

Hi @aaron.caito,
I wanted to check-in and make sure you are not still having this issue. If you are, can you take a look at my previous posts?

Hey Tony, thanks for your diligence here, sorry I’ve been on vacation, I’ll give this all a try in the next couple of days and get back to you!

1 Like

Hey Tony, appears it was a policy issue after all. Sorry for wasting your time.

I’m waiting for a long recurisve sync to finish in another thread before i mess with the agent but any ideas on: [ec2-user@ odrive-agent-mount]$ odrive sync example-aws-s3/ --recursive Error allocating decompression buffer Error decompressing libpython2.7.so.1.0 Error loading Python lib '/tmp/_MEI2YuUSS/libpython2.7.so.1.0': /tmp/_MEI2YuUSS/libpython2.7.so.1.0: file too short

Hey @aaron.caito,
Thanks for providing an update! For the error, this looks like something may be wrong with the binary. Is this happening all of the time, or was it a one-time error? Can you try downloading the agent again and seeing if you encounter the same error?

No worries about the policy issue. AWS policies aren’t exactly straightforward… :wink: Would you be able to tell me what the issue was, just for future reference, in case someone else runs into it?

Wasn’t using a managed s3 policy. S3 at some point added new capabilities that were not compatible with my s3:* on resource bucket. This made my policy begin to fail validation so access was no longer allowed. Switched back to using managed policy though I am going to make a new custom policy at some point.

1 Like

Thanks @aaron.caito!

Are you still seeing the error with the binary?

Nope, looks to have been an out of memory error. I am having issues constraining cpu consumption though to not exhaust my cpu credits. using cpulimit now which is mostly working. thanks you can close this.

1 Like