OpenDrive link not visible in Desktop

Hi all,
I have linked my opendrive account to odrive, but I can’t see that folder in my desktop. Nevertheless, I can access my opendrive account via odrive web.
Anyone could help me?

Hi @jorgeloscos

Would you like to try the following?

  1. Goto odrive tray menu “Open odrive folder”
  2. Right-click --> Refresh (with infinity icon) inside odrive folder. It should bring your “opendrive” link in your desktop client.

In case above doesn’t work then please post a snapshot of your desktop odrive folder and odrive web view (where folder is appearing)


Hi @AsifNisarr,
I did refresh my odrive folder as you suggested with no luck.
I have attached a couple of snapshots as you requested.
Thank you,

This is quite strange indeed. Visually, I don’t see any reason for OpenDrive link folder to not show up in odrive folder.

To help us further understand the described issue; can you please try out the following and provide the result / out-come:

  1. Exit and re-launch odrive app, It will kick off progressive sync which should fetch the missing folder, Does this help?
  2. Rename “OpenDrive” folder to “OpenDriveTest” temporarily, Does this help?
  3. Do you have any sync operation going on? It may prevent folder from appearing until sync job is completed.
  4. Is there any network / connectivity problem?

Finally, send diagnostic report, there is an option in odrive tray menu to send the report but make sure to let us know when the report was sent and Windows OS user name.


  • Asif

Thank you very much for your help.

I tried your suggestions and I found something (point 3):

  1. It doesn’t help. In fact, I manually upgraded to version 5354 (Windows 7), the same problem exists
  2. I renamed the folder on the odrive web, it doesn’t appear in my desktop
  3. I manually paused the syncs and refresh the folder in my desktop. Then, I saw the new OpenDriveTest folder as “waiting” when I click odirve system tray (Picture1). But as soon as I started again the syncs, OpendriveTest folder disappear (Picture2) and OpenDriveTest folder does not appear in odrive folder.
  4. No issues so far. I even temporarily disabled my antivirus/firewall and force syncing, with the same results.

How can I proceed next?

Thanks for providing more details and snapshot which clearly illustrates “OpenDrive” link folder is failing to create in your desktop odrive folder. Did you get a chance to send diagnostic report (from odrive tray menu)? also make sure to mention your OS username and time-stamp when the report was sent.

Your user correctly have write access to odrive folder and there is no permission issue in adding any folder into it, right? I’m expecting, the only problem you are facing is missing “OpenDrive” link but at the same time you are able sync your files in other sources (e.g. Google Drive)

Last thing to try, after sending diagnostic report is as following:
i) Unlink “OpenDrive” or “OpenDriveTest” from
ii) Exit odrive app
iii) Add “OpenDrive” link again
iv) Re-launch odrive app

I’ll further look into the diagnostic report as soon as I get it.


Thanks @jorgeloscos, I’ve got the diagnostic report and I do see something odd in logs which may be causing the “OpenDrive” link folder not to list in desktop client.

I’ll forward these details to our engineering team for further investigation. Meanwhile, please use odrive web client to access OpenDrive files / folder until I have an update on above issue or a possible fix available.

Thanks for your patience…!

Sorry for the delay, We have released our new desktop clients and it should resolve this problem.

Our engineering team has isolated another problem in expanding the OpenDrive If your timezone is ahead of GMT but I cannot promise when permanent fix will be available to end-users.

To overcome this issue, please temporarily change your Windows machine time zone to UTC-08:00 Pacific Time (US & Canada), Exit and re-launch odrive app and then try to expand “OpenDrive” placeholder folder.

You can change your time zone back to its original state after expanding OpenDrive folder and it should start working from there without need to change time zone in future.

Please let me know how it works if you are still using OpenDrive


1 Like

Dear Asif,
I did whay tou suggested and I’m happy to say that it finally worked (at least for now).
Thank you,

1 Like

Great, thank you…!

Please let us know if you have any other questions or concerns