Odrive won't sync to download or upload

My odrive has stopped syncing. I’m running Windows 10 and version prod6252, I’m also running McAfee LiveSafe. I tried to follow previous online advise to deauthorize, reinstall odrive, move files, etc. but nothing has worked so far and files won’t upload or download. I use my computer from a home connection but use other windows computers at the office and they have not had any issues of late. All of the folders will update and populate with the cloud files but will not sync and i get an error stating “Unable to sync xxxx.xxx.cloud.
Please check your network connection or manage your proxy settings.”

I am in a crunch for work and this is killing me. Please help


Hi @mryder

It definitely sounds like something is blocking your connectivity, and the anti virus would be the most likely culprit. Please make sure the odrive app is whiteflagged and allowed access and be sure it can reach both www.odrive.com and api.odrive.com

If needed please check the McAfee documentation to find the steps necessary to allow the program access through the firewall such as:


Thanks for the quick reply. I’ve whiteflagged www.odrive.com and api.odrive.com in McAfee WebAdviser. I also allowed un gurded access through the firewall for odrive, odriveapp.exe, and odriveopen. None of this has many any difference as it still will not sync in either direction.

Hi @mryder,

What cloud services are you using (e.g. Dropbox, Amazon, etc…)? Are those URLs being allowed through McAfee?

Can you send a diagnostic report from the odrive menu as well?

We are using google drive as the cloud service. I just tried to download via the odrive internet portal and it also won’t let me access files, getting this error "This site can’t be reached

The connection was reset.
Checking the connection
Checking the proxy and the firewall
Running Windows Network Diagnostics

It does appear that the url is being blocked but I can’t determine through what channel it is being denied. Thanks.

I also sent the diagnostic report


The diagnostic shows the same error you posted above. Are you perhaps behind a proxy or anything else that can mess with your connection? is www.googleapis.com being allowed through the firewall? Are you perhaps behind a proxy or VPN?

Can you reach https://www.googleapis.com/drive/v2/about without any ssl errors?

P.S. Keep clicking on the image below to get expanded views… the forum seems to have compressed it down into a thumbnail, so click on it a couple of times until it appears big enough to look at / read legibly (and so you can fully see steps 3, 4 , and 5)

Yes, I can reach https://www.googleapis.com/drive/v2/about without it throwing any errors. When I go to www.googleapis.com it just says “Not found” on the page. Below is what I see when I foolow the steps in the png you provided.

Hi @mryder,
I wanted to follow-up on this. Are you still seeing these errors? If so, were you able to determine if you had any firewalls or proxies within your environment that were blocking the connection?

Hi Tony, thanks for checking up on this. Yes, I am still getting these errors and odrive still will not sync nor can I access documents through the internet download. Other coworkers have said their odrive has stopped working as well and is stalled waiting on certain files. These are the same project files that were auto syncing when my odrive stopped syncing.

Hi @mryder,
It sounds like the IT department there may have started blocking odrive, or setup something that is interfering with it.

Just for clarity, you are not able to access files when using the Google Drive web client, directly, either? (https://drive.google.com/)

Same for the odrive web client? (https://www.odrive.com/account/myodrive)

Can you send one more diagnostic from the odrive tray menu, again?

I talked with our IT guy, we’re a small 30 person company, and he said they have made no changes and nothing is run through a proxy. Accessing and downloading directly from google drive works fine but it throws the same error when trying to download from the odrive.com access. Ijust sent a diagnostuc.

Thanks, I appreciate it.

Hi @mryder,
I think the fact that this happens on the odrive.com web client provides a good focus point. This eliminates a lot of variables. Can you take a screenshot of the screen with the error that you see from the odrive.com website?

Do you have any other storage links that you can test? If so, do they exhibit the same behavior, or is it only Google Drive?