Odrive Windows won't start after manual update to v6466

I noticed that my Odrive app on Windows 10 machine hadn’t updated to the latest version 6466 that has been available on the odrive website for a month, so I decided to manually update it by downloading the installer and running it. The installer got stuck and so I had to force close the installer and reboot my machine. On rebooting, the installer automatically re-launched and finished the install process successfully. I then restarted again and now Odrive will not launch at all, either at startup or manually.

I have tried uninstalling and reinstalling to no avail. I ran the odrive.exe file with verbose logging switched via the CLI, but the log file just says that it launched ok. When I open Task Manager, there is an entry for odrive.exe and odriveapp.exe, but there is no icon in the taskbar, and when I open Windows Explorer, there is no odrive integration in the sidebar, or when right-clicking.

Any ideas on what could have gone wrong?



Hi @paul_harris77,
I haven’t seen this type of issue before, so I’m not sure what could be causing it.

The odrive.exe is the tray menu app and odriveapp.exe is the sync engine.

When you double-click on a .cloud or .cloudf placeholder file, does it sync as expected?

When you right-click->properties on the odrive.exe and odriveapp.exe listings in the task manager, what are the paths listed at for “Location”?

As a test of the environment, you could try creating a new user on that system and seeing if odrive runs properly with that user’s environment.

Hi Tony,

The issue seems to have resolved itself. After several hours the set up page suddenly came up. Not sure what was going on, something must have been blocking.

Thanks anyway.


Hi @paul_harris77,
Thanks for the update! I’m glad to hear it is working. Does it start up right away now, after exiting and restarting?

Seems to :slight_smile:


1 Like