Odrive stopped working catalina OSX

I cannot get odrive to open at all in catalina, it seemed to be working fine a while back - but now it opens and then ii see the processes, and then it vanishes; is there a way to fix this even if its temp? ive got lots of files i need to sync/unsync

The processes in finder are still there, it just tells me ‘no options available’

I found this in another thread:

killall -KILL odrive; killall -KILL FinderSyncExtension; sleep 5; cd "$HOME"; rm -r ".odrive/bin"; rm ".odrive/version"; open "/Applications/odrive.app"

which has got the app back and now syncing again -

Thanks for the update @alex! I was going to suggest this, as well.

We need to enhance our installer to account for this so that a re-install will also address this issue when it crops up.

Hey BEFORE YOU DO THIS, make sure to note that this command removes all your files in your ODRIVE. I was just looking for a hasty fix and did this quickly… but note. I was trying to sync files up and noticed it wasn’t working. When I ran this fix, although it worked, it did delete my files that I was trying to sync up. SO JUST BE AWARE OF THIS. You should really warn people that might not be as fluent with terminal commands of what this is going to do.

Hi @edward,
This command doesn’t actually touch the odrive data folder. I’ll walk through what it does so there is no confusion.

killall -KILL odrive; killall -KILL FinderSyncExtension; sleep 5; cd "$HOME"; rm -r ".odrive/bin"; rm ".odrive/version"; open "/Applications/odrive.app"

  • killall -KILL odrive; - This kills any running odrive processes. This probably won’t do anything because the problem we are trying to solve is that odrive doesn’t run, but it is there, just in case.
  • killall -KILL FinderSyncExtension; - This kills any FinderSyncExtension processes, which is the odrive Finder extension.
  • sleep 5; - Wait for 5 seconds before continuing
  • cd "$HOME"; - Change to the user’s home folder.
  • rm -r ".odrive/bin"; - remove the ~/.odrive/bin folder. This folder contains the odrive binary executables (not to be confused with the ~/odrive folder)
  • rm ".odrive/version"; - remove the odrive version file in the ~/.odrive/ folder (again, not to be confused with the ~/odrive folder). This is used internally for installs and upgrades.
  • open "/Applications/odrive.app" - This opens the odrive application, which should now replace the problem files we removed in the previous commands.

The outcome of this command is that it will replace the odrive executable binaries. This will leave all of the odrive data folders and the odrive local databases untouched, so you should not have any impact to your files, in any way.

There is another command to uninstall odrive. In that command the odrive data folder is renamed to a backup name. If you are not aware of this rename it can look like the odrive folder was deleted. Here is more specific information on that command:

Is it possible that you ran the uninstall command and the odrive folder was renamed?

I always make sure to take extreme care when posting any command line snippets to ensure that no user data will be deleted. It is something I am hyper-sensitive about.

I see… I looked back through to try and figure out what happened and since I updated to Mac OS Catalina right at the same time as running these commands, the installer (i.e. Apple Computers) took the liberty to completely relocate the Odrive folder to a “Shared” directory. I’m assuming it’s for security reasons, but there was no notification of this change other than maybe the fine print.

Okay, My mistake. I got everything now. Thanks.

1 Like

Thanks for the follow-up @edward!

It is disconcerting to hear that MacOS decided to move the folder during upgrade. I haven’t seen that yet, but we’ll see if we can reproduce. Unfortunately there isn’t a whole lot we can do if Apple just up and decides to move things around.