Odrive right click context menu missing in Windows 10 File Explorer & auto-download not working

Hi, I’m experiencing two problems using Odrive to sync my Amazon Cloud Drive folder with my Windows 10 laptop.

  1. I do not see any odrive options in the right click context menu in Windows explorer. I only have odrive options when I access the odrive menu from the task bar icon. I’ve noticed I’m missing the following registry key:
    HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows\CurrentVersion\Explorer\SyncRootManager\odrive!S-1-5-32-544!mainFolder

In fact, I do not have the SyncRootManager folder at all. Could you please provide the text needed to create this registry key manually, if that is what it takes to fix the problem?

  1. My global settings via the Odrive task bar icon menu are set to auto-download. That said, not all my files are downloading, even though I have ample hard drive space and have reinstalled odrive multiple times. In particular, I’ve noticed I need to click through to each subfolder manually, in order to force a download (which sometimes works, sometimes leaves non-downloaded odrive stubs). Files in the root Amazon Cloud Drive folder do not download, even when I try to open them with a client application on my PC. IT’s just non-responsive.

Could you please advise on how to correct these problems? Thank you!

Hi @jwickland,

  1. The SyncRootManager entry isn’t needed for the Explorer shell extensions (context menus and icon overlays). In fact, we are planning on removing the SyncRootManager entry because it seems to no longer be needed.

Are you seeing any icon overlays (green checkmarks or link sync badges) on your files, or are those missing too?

  1. The auto download limit is only used to determine if newly expanded folders will download the files inside or not. If you want to sync down everything you will need to use the recursive sync feature:
    https://docs.odrive.com/docs/sync-your-odrive#section--sync-all-files-and-subfolders-

Unfortunately you can’t access this without the right-click context menus, so we will need to figure out what is going on there.

I do not see the icon overlays either. How do I get the right click context menu back, so I can use the recursive sync feature?

Hi @jwickland,
Do you have any anti-virus or other applications running that actively monitor the system? It is possible that an app like this could interfere with the communication between the Explorer extensions and odrive.

If not, we can try some additional debugging using the instructions here:

Once Explorer is restarted, try right-clicking on an odrive folder and then send over the “ContextMenu.log” and “ActiveOverlay.log” that should be on your Desktop.

Followed the process described. I don’t see anything new – including dump files – in my Desktop. Where do I find those?

Also, I don’t see any odrive entries in HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows\CurrentVersion\Explorer\ShellIconOverlayIdentifiers. Should there be some? How many and what would they be called? I assume they need to be listed among the first 15 to show?

Thanks!

Hi @jwickland,
I’m not sure why, but it seems like the install did not add all of the required entires (or they were blocked somehow). Can you try uninstalling and reinstalling to see if the new install will correct these issues?

Do you have any software running that could be interfering with install, like anti-virus or other actively monitoring software?

Hello – I’m having the same issue on Windows Server 2008 R 2 [Windows 6.1.7601]. The odrive options are missing from the explorer context menu. I have tried reinstalling and restarting Windows.I also tried the steps above to generate odrive logs but there is nothing on my desktop.

Also… we are not running any Antivirus or other software which would block installtion.

Hi @sharedplaylist,

Are you seeing the file/folder sync badges?

There are a couple of things we can check to see where the gap might be. The first is this:

That will tell us if explorer is loading the required DLLs, at all.

If the DLLs don’t seem to be loaded, the next check is this one:

Ok. I’ve done all of the above and contextmenu.dll is still not loading.

In SysInternals Process Explorer contextmenu.dll was not found so I disabled / re-enabled the odrive extensions using ShellExView. I restarted Explorer.exe (all instances) and checked my odrive folder. The contextmenu is still not loading. I rebooted the PC and still not seeing the contextmenu before and after repeating the above steps.

This seems to indicate that Explorer is not loading the dlls it is supposed to. Do you have any software running that could be preventing extensions? Since this is running on a Server OS, are there any policies or restrictions in place that could be preventing it?

When using shellExView, do you see any other 3rd party extensions and are those working correctly?

We do not have any of that type of blocking software installed. Also we have been able to install other software that installs shell extensions such as TortoiseSVN, Google Drive, 7zip, and VLC.

Here are the items loaded as shown in ShellEx: http://pastebin.com/ZXqpu7ww

I hadn’t tested 2008r2 for a while, so I spun up a vanilla 2008r2 instance in EC2 and installed odrive, thinking that it may be something specific to 2008. Unfortunately I was not able to reproduce your issue. I can see the icon overlays and context menus without any issues.

Since ShellExView shows the extensions as enabled, it just seems that, for some reason, Explorer is not loading them. This is evidenced by no log generation with debugging enabled and you do not see the DLLs loaded when viewing the Explorer in Process Explorer.

I suppose one more thing to try is to login as a different user on that machine and see if the problem is user-specific, or system-wide.

Yeah I tried another user account. It’s system-wide. Maybe Tortoise is interfering. I will try removing other extensions to see.

Hi @sharedplaylist,
Did you have any luck with this?

I had a similar issue. I was able to fix it by emptying my odrive trash. It seems to be a problem when too many items accumulate (which can happen when you have trash set to empty - never as I did) and odrive cannot enumerate all the items for displaying in the menu, crashing the contextual menu.

1 Like