Odrive not sync in domain and firewall setting?

Hi, I have amazon cloud storage unlimited which I am using odrive to sync to backup my files. My odrive is in a domain controller setting behind a proxy firewall router. I noticed odrive dumped all the unsync files into the trash when did not sync with amazon could.storage. Currently, I have approx. 1,700 files in the trash. I added the necessary port 4433, and 4434 along with the firewall exception in the DCl, but it is still not quite syncing fully. Through the proxy router, I also noticed the bandwidth of the odrive is syncing very little, under 1 mbps. What am I missing? Thanks for your input.

Can you tell me what trash you see the files in? Are these in your OS trash or in the odrive trash? Can you provide a screenshot?

Are you seeing that files are syncing properly?

Is this backup being performed on a corporate/business network or a personal network?

You mention port 4433 and 4434, can you explain where you came by those ports? Those are the ports that were used in a legacy file server product we have, but are not applicable to the odrive desktop client.



Thank you for your reply.

The trash I see is the trash files when we right click on the odrive app at the task bar. Please see attachment.

What I notice is that some files are 100% synced and some not not. The ones that are not appeared to end up in the odrive trash.

The files are personal business backup files that are done daily. I have 100 mbps up and 100 mbps down. So the bandwidth issues is not an issue here. But, I can’t seem to get the odrive function properly.

Thank you very much for the port information, and your assistance in making this work.

Allen H

Hi Allen,
Files in the trash will generally only appear there if the files are already in the cloud. The odrive trash is a holding area to prevent inadvertent remote deletes. When you restore them they will appear as .cloud/.cloudf files, representing their remote counterparts.

I’m not sure about the speed issues you are seeing yet, but let’s try to take care of the general syncing first. For the files listed in the odrive trash, do you see them via the odrive web client or Amazon web client?

The file list in the odrive trash when I opened them, contains the .cloudf , .cloud , .pdf , .jpg … etc.

I verified them to determine whether they are already inside my amazon cloud storage. I discovered some files such as the .cloud files are already in the synced Amazon cloud storage. Some files such as the mentioned .pdf , .jpg …etc are not.

Thanks Allen.

Can you send a screenshot of what you are seeing along with sending along a diagnostic (located at the bottom of the odrive tray menu)? I will take a deeper look.

Please find uploaded printscreen as per requested. Please also find diagnostic executed. If you did not receive them, thank you for letting me know.

Thanks. Looking at the diagnostic I can see that there is a problem trying to communicate with Amazon Cloud Drive (SSL: UNKNOWN_PROTOCOL). This seems to be the root cause.

This indicates that something is interfering with the client’s outbound communication over port 443. You mentioned a firewall. Is this inspecting traffic and possibly blocking or creating interference?


Hi Tony,

Thank you for your patience.

I am sorry it takes this long to get back to you.

I also had amazon cloud storage drive installed, in addition to Odrive app. Both did not work and not syncing. After this workstation was promoted to DC, I had added firewall alias, firewall exception to the DC but it is not just syncing consistently.

Besides the firewall, we also have squid proxy server but did not set up squid reverse proxy. Could this be the cause?



Dear Tony,

Thank you for providing outbound communication port 443 blocked. To my research discovery as you are not probably aware, the squid proxy server outbound takes over precedent the router firewall outbound rule setting whereever there is a squid proxy server. Since the squid proxy port is configure using a specific port, can you share how to change the odrive’s port setting to match the squid proxy server’s port setting to ensure 443 oubound will go through. Like the browser’s proxy server requring additional proxy setting, thank you for sharing to configure the proxy setting in odrive.


Hi Allen,
Currently the odrive desktop client doesn’t support setting proxy configurations, but it is a feature that we would like to get in in the future.