Odrive not appearing in system tray (MacOS) - Can't empty trash

The odrive icon is not showing up in the system tray. I am using MacOS Monterey 12.6 on Apple M2 Chip; Odrive version 7334. I double click on Odrive in Applications but that does not help.

Odrive is still running/syncing, since files I add to cloud storage are getting downloaded to my Mac, but I would like to access the system tray so I can empty the odrive trash.

How I can either get the odrive icon/menu to appear in system tray or to empty trash without the system tray menu?

Hi @datschris222,
This is definitely strange.

  • Were you seeing the icon previously and now it has stopped showing up?
  • Have you tried restarting the Mac yet?
  • Any possibility the icon is actually there, but it is hard to see due to a combination of the theme and the background?

Hello, thanks for your response. After rebooting 4ish times, the system tray icon came back. Some combination of rebooting and reducing the number of other icons seems to help but can’t pinpoint exactly what did it. I was able to successfully empty my odrive trash. Thanks!

1 Like

Thanks for the update @datschris222!

It sounds like the odrive icon may have been being crowded out by other icons. I know that this can be an issue once the number of icons becomes high. There are some applications that Mac users will use to try to manage this (Dozer and Bartender, for example), although I haven’t tried them.