Odrive macOS not syncing

This is for the encrypted folders

Autosync doesn’t seem to work. It just sits there saying “Ready to sync”

When I access the main folder for the encrypted folder and right click it gives me the odrive options to sync, unsync and refresh. (I’ve tried refreshing a couple of times)
Once I go to any folder or .cloudf under the main folder, the odrive options no longer show up. It just says No options available.

Not sure where to go to sort this out.

I tried to reinstall odrive and it doesn’t seem help.

Any assistance would be much appreciated.

Hi @brian.neu,
Can you clarify what issue you are seeing? If you select “sync” when right-clicking on the folder, that will pop-up a window that gives you a bunch of options for syncing that folder, including setting up folder sync rules: https://docs.odrive.com/docs/sync-your-odrive#section--sync-all-files-and-subfolders-

The “no options” showing may mean that odrive is still initializing. Did you recently add a lot of data into odrive?
Can you send a diagnostic from the odrive menu so we can take a closer look?

Left the computer on and it still hasn’t finished initializing? I added 34gb of data. 17 gb 2 days ago and 17gb again today.

I did notice that it’s not starting with startup.

Oh I’ve just sent the diagnostic. Thank you for looking into it.

Hi @brian.neu,
The diagnostic didn’t reveal any apparent issues.

Did you add the new files locally to be uploaded, or were they added remotely and you want to download them to your local system?

I just want to clarify what behavior you are expecting vs what you are seeing. Can you provide some additional details on that?

I added the new files locally to be uploaded.

Actually I think it’s been somewhat ongoing as there’s another 60+ gb which hasn’t unsynced from my odrive and I set it to unsync after a week. I added 17gb of photos 2 days ago and the 60 gb was likely added a month or so back.

The situation right now is that new files aren’t being uploaded and aren’t being unsynced after a week. I generally use odrive to keep all my old diving photos after I’ve finished processing them.

I hope this paints a clearer picture.

Hi @brian.neu,
Thanks for the clarification.

I took another careful look at the diagnostic and I actually do see an issue. It looks like the local tracking database is in a bad state. It is a subtle, unexpected issue, but I can definitely see it. This would explain why you are experiencing these issues.

I am not able to tell how long you have been in this state, but may have been quite a while. I am guessing that any files that you see have not yet been unsynced have probably not been uploaded.

The only way to correct for this, unfortunately, is to rebuild the local cache, which essentially means an uninstall and reinstall.

Important notes:

  • Since you have files on the local system that have not been uploaded yet, you will want to copy those out to another, safe location before uninstall.
  • Once your local files and folders have been copied to a safe location, uninstall odrive and then install again and login.
  • Move the copied files back into the proper locations in odrive and sync should resume without any more issues.

Please let me know if you have any questions on the above steps.

Uninstalling odrive and installing again seemed to work.

Unsynced files were copied to an external drive (still had one laying around! lol). After I uninstalled and installed, odrive took about 10 minutes before attempting to sync the unsynced files which were in the original odrive folder.

Thanks. Is there any way to avoid issues with the local tracking database?

Great! Thanks for the update @brian.neu.

These types of issues aren’t common. We usually see it under these circumstances:

  1. Sudden power loss to the system, which can impact the database if it is in the middle of writing
  2. Killing the app (not a graceful exit) while the database is being written to
  3. Running out of disk space during database writes
  4. Bad sectors on a drive or a failing drive