Odrive Icon in the Taskbar Keeps Disappearing on Windows 10

I am new to odrive and have installed the software on my iMac and MacBook Pro in the last few days. I also use the Windows version of the software on the virtual Windows 10 setup I have on both of my Macs via VMware Fusion. For whatever reason the odrive icon that appears in the taskbar keeps disappearing whenever I have to restart Windows 10. Despite this the odrive software appears to be running and the files are being kept in sync. I have checked the Windows 10 setting for to “select which icons appear in the taskbar” and odriveapp.exe is set in the “ON” position so I am really baffled. I also tried the complete uninstall process and reinstall of the software as listed in the FAQs and whereas the odrive icon appears in the taskbar after the reinstall it either disappears shortly thereafter or after the aforementioned restart of Windows. Would appreciate any help to get this resolved as that icon is very helpful in seeing progress of the various syncs I have setup and this problem does not exist on the Mac side of the software.


Hi @john355,
Let’s try running odriveapp from the command line to see if it is spitting anything out:

  1. Open a command prompt (cmd)
  2. Copy and paste the following and hit enter:
    cd "%userprofile%\.odrive\bin" && dir
  3. The above command will list at least one four digit directory (like 5203). You will then wan to use that number in the following command:
    Make sure you use whatever number you have, if it is not 5203

This will launch odrive and hopefully spit out something useful that we can use to diagnose what is happening.


Hi Tony:

Firstly, thank you so much for offering to help me with my issue. You response time was amazing! I am not that good with MSDOS commands but can generally get through them. I finally figured out that I did not need to copy literally what you wanted me to on the CMD prompt and was able to get done what you needed me to do. I have pasted a screen shot from my Windows 10 VM. When I typed in the “odriveapp.exe” you can see I got a response of “QML” and then the odrive icon was back on the taskbar! Not sure how long it will hold but I am hopeful. What does the “QML” response on the command line mean? Is there something else I need to do or should I just keep monitoring this situation and report if the icon disappears again?

As always, thanks for your assistance! I really love using odrive as I never know I could tie all my Cloud storage spaces together in such an easy manner!


Hi Tony -

Just wanted you to know the icon disappears again when I went to click on it to change a setting. I was able to bring it back again by following your steps but hopefully I will not have to do this every time I need the icon back in the taskbar.


My apologies, my instructions may not have been the most clear. It was late ;).

You did it right though. So what I am interested in is if anything is spitting out after the tray menu disappears. Can you show me what you in the command prompt after that? It will be something after the qml you showed above.


I actually did not do anything after that as it responds with the “QML” but does not return with a command prompt of any sort. Not sure if this will help you or not. But as long as I leave the command prompt in a minimized state on the windows desktop the odrive icon stays active. If I go to close the command prompt window and then click on the odrive icon in the taskbar say to see the meny settings the icon once again disappears and I have to start the command prompt backup and launch odriveapp.exe to bring it back.

It looks like odrive is not experiencing the issue you were seeing earlier, at least not with this method of execution. I don’t expect you to run like this normally. This is just for testing. If you close this window (which will close odrive, as you have seen) and run odrive normally, are you still seeing the issue you were seeing before?

Hi Tony:

Unfortunately yes I am. I even restarted my Windows 10 VM and tried to start odrive from the start menu and it did not do anything. Only able to get the icon back when I do the command prompt steps.


For clarity, when starting odrive from the start menu, it never starts at all (the icon never appears)? I thought it was starting then stopping.

If it is never starting then can you do the following?

  1. Stop any odrive processes
  2. Open up a command prompt (or use one that is already open)
  3. Copy and paste the following and hit enter:
    "%programfiles%\odrive\odrive.exe" -v > %userprofile%\Desktop\odrive_log.txt

This will create a logfile on your Desktop called "odrive_log.txt. Can you attach that here?


Hi Tony:

Sorry for any confusion. Yes it does not appear to start at all when doing a restart. I thought it was starting and stopping as well but that may have been a fluke. Once again and please be patient with me, I am not sure if I am literally to copy exactly the command line that you have listed or replace with the unique directories of my Windows 10 VM setup. Can you please clarify that as well as where in the command prompt I should be running this command line from such as the C:\ root directory?


No worries John. This is more advanced stuff so its okay if you aren’t just breezing through. :slight_smile:

In this case the command can be copied, verbatim, into the command prompt. It doesn’t matter where you are currently located.


Did what you said as follows:

But yet I could not find the text file. It looked like it was doing something but nothing happened. It is getting late so we can pick this up tomorrow as your convenience.


Darn. I should’ve put quotes around the Desktop part:
"%programfiles%\odrive\odrive.exe" -v > "%userprofile%\Desktop\odrive_log.txt"

BINGO! That did the trick and created the text file. It also started the odrive app and even with the CMD window closed it appears to remain in the task bar. However, when I did a restart the icon was gone once again. It won’t let me insert the text file into this dialogue as it says I am a “new user” so I copied and pasted what was in the log file as follows:

Starting launcher with verbose output…

No product argument was passed in. Attempting to find product.conf…

Using path C:\PROGRA~1\odrive\product.conf…

Using C:\Users\John’s MacBook Pro.odrive as the installed folder path…

Attempting to mark the installed folder path as hidden…

Writing the product.conf file at C:\Users\John’s MacBook Pro.odrive…

Reading the version number from the version file…

Attempting to read systemAlertRoom from config…

Setting up diagnostics for buildNo: 5203, productName: prod, systemAlertRoom: 1358891

Creating launcher object…

Checking if another odrive process is running again to reduce the chances of a race condition…


Launch succeeded!

Hope this helps you.


PS: Interestingly, if after the Windows restart I go to the task manager and end the odriveapp.exe and then open the CMD window and type in “%programfiles%\odrive\odrive.exe” the odrive app starts and stays on for this current session EVEN if I close out the CMD window. Not sure if that additional information helps you or not. Good night!

Thanks. This appears to be working correctly. What is odd is that you are seeing the process run normally when running it this way. It doesn’t make much sense.

Can you confirm that if you launch odrive by double-clicking the C:\Program Files\odrive\odrive.exe the problem presents itself, but does not when launching that same process from the command line?


Hi Tony:

Yes I can start odrive from either method as long as I go to the task manager and end the running odrive process first. If I do not do that then it will not start odrive from either the command prompt or the file explorer screen,


Hi John,
Can you go over with me where you are still seeing the problem (what scenario)? It sounds like it is working, but I think I may be missing something. If you exit odrive normally from the tray menu -> Exit, then start odrive from the shortcut is that working now, or still no? If no, if you exit normally then start from File Explorer, does that work?


HI Tony:

Not sure what happened but on both my iMac and my MBP Windows 10 VMware Fusion setups the odrive icon is working just the way it should. I tested both by exiting the app in the taskbar and then selecting the shortcut from the start menu under most frequently used app tiles and it started right up!!

We are all good now.

Once again thanks so much for all your help as well as your patients in walking me through the MS-DOS commands. I actually learned some new skills from that not that I plan on going to the Command prompt to often! :smile:

Have a GREAT weekend and thanks for introducing to such a wonderful program that ties all my storage spaces together!!


1 Like

Great! I’m glad it is all sorted out. Just let me know if anything else comes up. Enjoy your weekend!