ODrive for Mac + GDrive: Odrive keeps asking for authorization

Hi there.

I just installed ODrive on a Mac with OS 10.11.3. Added two different GDrive accounts just fine, their links appeared correctly in the odrive local folder.

When I tried accessing or syncing them (using the local Finder window), I was asked to authorize offline use of my GDrive accounts, which I did, successfully.

But then nothing happens, and if I try accessing the folders, the same process happens all over again (request for authorization, success, nothing happens…)

Note that the odrive web interface to each of the two links works fine, and I am trying to access two Google Apps for Work accounts.

Help, please!

To be clear, you can access both linked accounts just fine using the odrive web client (www.odrive.com)? Can you browse through them without any errors on the web client?

Please try the following:

  1. Go to the odrive web client (https://www.odrive.com) and sign-in to your odrive account
  2. Unlink both of the problematic Google accounts
  3. Go to the odrive desktop client and right-click->refresh on the main odrive directory to ensure that the desktop client sees that the accounts have been unlinked.
  4. Link one of the accounts from the web client and confirm that you can navigate through just fine from the web client
  5. Refresh again on the odrive directory on your desktop
  6. Double-click on the new link (from step 4) and see if it works this time.

If you are still having the same issue, please send a diagnostic from the odrive tray menu.


Hi Tony.

Yes, access through the odrive web client is flawless.

I’ve done all the steps your suggested: web still works OK, but the desktop client keeps asking for authorisation. Which I grant, but then nothing happens. Next time I double click on the same link on the desktop client, it asks for authorisation again.

I’ve just sent the diagnostic data from the tray menu.


Unfortunately the diagnostic didn’t come though. Do you happen to have a proxy in place, or any other type of network intermediate that your traffic is passing though other than the standard router/modem?

Are there any other links you can try to test, to see if the behavior is the same? I get the feeling that this is a network issue of some kind, but the cause is still unclear.

Hi Tony.

The only proxy I have is local on my machine, it’s GlimmerBlocker. I just tried disabling it, but the result is the same.

I’ve re-sent the diagnostic just a few minutes ago: hopefully you’ll get it this time.

I tried adding another Google Drive link, this time a “non-Apps-for-Work” account: same result.

I also tried with my Dropbox account: works fine through the odrive web interface, but the Finder app gives me the following result (see attachment) when double clicking on the link.


From what I can tell there is something impeding the network requests in some way. Unfortunately I can’t tell what because it is also preventing the diagnostic reports from being sent properly.

Are you certain there isn’t anything between the app and the external network that could be interfering or manipulating traffic?

Yes, I’m pretty sure. I’ve tried disabling the HTTP proxy, but still no luck.

Also, I get the same errors while at home (ADSL), work (100Mbps fiber), or at a partner’s office (10Mbps fiber), all with different setups and operators.

Every other network service I use works fine.

I’ve sent again the diagnostics: third time’s a charm? :wink:

Also, if you could let me know what to look for (TCP/UDP ports, IP addresses), I can capture traffic and see what’s going on myself.


We are using standard 443 (https) to the various services.

We can try running the app from the terminal to see if it is spitting anything out:

The 5127 could possibly be a different number.

Also, try deuthorizing and reauthorizing from the odrive tray menu: Authorized User -> Deauthorize

Running odrive from the terminal tells me that “osascript: OpenScripting.framework - scripting addition “/Library/ScriptingAdditions/QXPScriptingAdditions.osax” cannot be used with the current OS because it has no OSAXHandlers entry in its Info.plist.”

But I don’t think this is related to the issue I’m having.

tcpdump shows various connections from odrive to TCP/443, so that shouldn’t be an issue.

I’ve also tried the “Windows way” (rebooting), and deauthorize/reauthorize my user.

Unfortunately the results are always the same, with or without my local HTTP proxy.

I’m not sure what else to do. I really wish I could use odrive…



the osascript error is interesting, but shouldn’t be causing problems like this, although I will look into it.

When you mentioned the 3 different networks you’ve tested on, this was all with the same computer? Is it possible to create a second test user on the machine to see if the behavior is the same? Do you have any other machines you can test on?

Can I ask how you are setting/unsetting the proxy?

The proxy is systemwide on my machine: https://glimmerblocker.org

There’s a function, accessible through “System Preferences” that simply fills in the HTTP proxy field of every active network interface, or disables the proxy all together.

But, GlimmerBlocker is NOT the culprit!

I’ve just created a brand new user and… voilà! On the test user everything works as expected, with or without the proxy.

Now I need to understand where things go wrong with my user… I’m not sure where to start from.

Interesting. Thanks for the update! Please let me know if you are able to discover anything.

Tony, any chance that the odrive app on the Mac leaves any log, so that I can check what’s wrong?