Odrive doesn't sync a specific folder for Google Drive on Mac


I tried to sync my new folders to the Google Drive by adding it directly to the Odrive folders. But for some reason a specific folder does not seem to sync. I am currently on free mode but it was still the same even when I was on premium. I am not sure what to make of it. I tried testing the Odrive with a small html file to see if the system had an overall problem. However, the html file does sync flawlessly. Why is this happening? It keeps on giving on me that Odrive cannot sync this folder and I am very frustrated that the Google Drive isn’t updated. Also, it’s on a perpetual ‘wait’ mode when I am trying to sync this specific folder. HELP!

Hi @untediousness,
Can you send a diagnostic from the odrive menu and tell me the full path to the folder that is not syncing?

When you send a diagnostic it will also create a file named “current_odrive_status.txt” in the root of the odrive folder. Can you attach that here, as well?


Permanent Storage/GNUC

**GNUC folder seems to not sync

I attached the report just like you requested.

current_odrive_status.txt (3.2 MB)

Weird. Now it’s in the progress of syncing.

Are there problems when I make the files available for ‘Shared Drive’ option for the Google Drive? Just for testing purposes I actually did take it out and now it seems to sync better.

Hi @untediousness,
I think you are talking about the “Team Drives” folder. You can’t add items directly to this folder because it is a container for your Team Drive folders.

You would need to either put the folder inside an existing Team Drive or create a new Team Drive to put the folder in. In other words, it would need to be something like odrive/Permanent Storage/Team Drives/[Some Team Drive Folder]/GNUC