Odrive creates random data files when synced with S3 storage


I set up a link to Amazon S3 on odrive. When I sync a folder from my Dropbox and I select the path folder on odrive, it correctly syncs that folder to odrive. I can view this through https://www.odrive.com/browse.

On S3 however, the folder and subfolders are not synced correctly. They are being uploaded as a list of gibberish data-string folders with data-string images such as folder names:


I don’t know what to do - I tried everything and followed the steps exactly as stated on the forum and guides so link s3 to odrive. PS. I just upgraded this morning to premium, not sure if that makes a difference.

Hi @Ryousef,
Did you choose the S3 Enhanced integration type vs the simple delimited? Please take a look at this thread for more information about this these two options and which one is right for your use case:

Yes - that worked now - Thank you! I had misunderstood that section when I first read it. I thought we should NOT choose the delimited option if we have an existing bucket. Thank you for clarifying and for your prompt response!

1 Like

Great! Thanks for confirming.