Odrive app will not run on Mac running High Sierra 10.13.1

I noticed the other day the files were no syncing in the odrive folder on my Mac. I then noticed the icon was not in the tray at the top of my screen either. I then launched the app again and got no response. It is as if I didn’t even click to open the app. I checked the activity monitor and I will sometimes see the odrive process launch when I click it but it immediately closes.

Please help! Thanks

I will also add that I have uninstalled and did a fresh install 2 times already with no success.

Hi @DanMc,
Let’s try running from the terminal to see if it shows anything helpful:

  1. Open a terminal session (type “terminal” in Spotlight search):

  2. Run the following command in the terminal session (copy & paste + Enter):


    bindir=$(ls -d "$HOME/.odrive/bin/"*/ | tail -1); echo $bindir;"${bindir}odriveapp.app/Contents/MacOS/odrive"

1 Like

I ran then command and now the terminal is just sitting at the >. Should I enter anything else? I am not even seeing an odrive folder after the install. What should I try next?

Daniels-iMac:~ dan$ bindir=$(ls -d “$HOME/.odrive/bin/”*/ | tail -1); echo $bindir;"${bindir}odriveapp.app/Contents/MacOS/odrive

Hi @DanMc,
It looks like you are missing the last quotation mark ( " ) at the end of the line. Can you try copying and pasting the command again, including that final quotation mark?

You are correct. I pasted the correct command and now I see the odrive icon on the top of my screen. When I do to the odrive folder where are no folders in there. What should I do next?

Hi @DanMc,
If you see the icon now, you should be able to click on it to show the odrive menu. In that menu is a setup option that will walk you through the login process. At that point your odrive links should show.

I am also having trouble with Odrive not starting on High Sierra. Reinstalled but won’t launch. Attempted command above but get an error after Odrive launches for a second and then closes.

Traceback (most recent call last):
File “”, line 20, in
File “”, line 18, in main
File “”, line 13, in launchDesktopApp
File “Odrive_Mac_Master_Build/src/odrive_app/OdriveDesktopApp.py”, line 334, in Odrive_Mac_Master_Build.src.odrive_app.OdriveDesktopApp.OdriveDesktopApp.construct (/Users/admin/hudson/workspace/Odrive_Mac_Master_Build/deploy/build/src/odrive_app/OdriveDesktopApp.c:6971)
File “Odrive_Mac_Master_Build/src/odrive_app/OdriveDesktopApp.py”, line 1114, in Odrive_Mac_Master_Build.src.odrive_app.OdriveDesktopApp.OdriveDesktopApp._get_odrive_fs_service (/Users/admin/hudson/workspace/Odrive_Mac_Master_Build/deploy/build/src/odrive_app/OdriveDesktopApp.c:25967)
File “Odrive_Mac_Master_Build/src/odrive_app/OdriveDesktopApp.py”, line 1079, in Odrive_Mac_Master_Build.src.odrive_app.OdriveDesktopApp.OdriveDesktopApp._get_database_key (/Users/admin/hudson/workspace/Odrive_Mac_Master_Build/deploy/build/src/odrive_app/OdriveDesktopApp.c:25125)
File “Odrive_Mac_Master_Build/src/utility/KeyChainService.py”, line 66, in Odrive_Mac_Master_Build.src.utility.KeyChainService.KeyChainService.set_user_key (/Users/admin/hudson/workspace/Odrive_Mac_Master_Build/deploy/build/src/utility/KeyChainService.c:3692)
File “/Users/admin/git/juggernaut/deploy/sandbox/lib/python2.7/site-packages/keyring/core.py”, line 45, in set_password
File “/Users/admin/git/juggernaut/deploy/sandbox/lib/python2.7/site-packages/keyring/backends/OS_X.py”, line 63, in set_password
keyring.errors.PasswordSetError: Can’t store password in keychain

Hi @derekgregg82,
I have seen this issue one other time. The thread is here: Odrive (build 6316) won't start on MacOS El Capitan 10.11.6

I just upgraded to Mac OS Mojave and now odrive wont launch. Seems similar to this issue. I tried the terminate command and it did open odrive in the task bar but if I quit terminate odrive quits as well. Any suggestions?

Hi @bill4,
To clarify, when trying to launch the odrive app the typical way (from Applications), odrive will not run, but using the terminal command above will allow it to run?

Try running this command from the terminal:

killall -KILL odrive; killall -KILL FinderSyncExtension; sleep 5; cd "$HOME"; rm -r ".odrive/bin"; rm ".odrive/version"; open "/Applications/odrive.app"

This will reset the odrive bin folder, which may get things working again.

1 Like

That worked! Wasn’t sure at first and the terminate was responding with “nothing found” but I then launched odrive and it started up and it now running fine! Much appreciated.

1 Like

When I run the command in terminal it opens ODrive but as soon as I close Terminal Odrive closes too.

Please fix this.

Hi @alvarez2,
After running this and then closing odrive, try opening odrive normally.

The open command at the end should be be disconnected from the terminal (by Apple’s design), so it is odd that a terminal close would affect odrive in that way. The intention of the command is to correct for any odd behavior with the application binaries, so once the situation is corrected you should be able to run the application normally. Are you running 10.13?