Odrive agent: Unable to sync Z:\MyPath Path not found

Hi all,

Back with some oddities… From one day to another, agent stopped replicating my files.
For debugging purposes, I rebooted the computer, started agent from powershell, authenticated then tried to mount, here’s what I got:

PS C:\Users\Me> & "C:\Users\Me\.odrive-agent\bin\odrive.exe" mount "Z:\MyPath" "/Google Drive/MyPath"
Unable to sync Z:/MyPath Path not found.
PS C:\Users\Me> cd z:\MyPath
PS Z:\MyPath>

As I’m not 100% confident in Corp. Firewall and Antivirus, I tried from another computer, using exactly same commands as described above and same environment… and… it was working !!

Only difference is that faulty computer is running Windows 10 and test computer, Windows 7.

Is there any way to debug further? Do you have any idea of the problem? Any suggestion?
NB. there’s absolutely nothing in the logs (from C:\Users\Me.odrive-agent\log)


Hi @D_Sec,
Hmm… that is odd.

Is it possible that the odrive agent loaded before Z: was ready (I am assuming it is a network drive)?

Are you able to mount to a folder on the local disk? What about another folder on Z:?

Hi @Tony,

Thanks for reply… well a bit ashamed, probably tried too many things at the same time…
But this morning, I tried again to shutdown agent, restart it and mount the directory.

Network drive started to sync with odrive without complaint.

So I guess that indeed agent was starting before Z: drive was mapped even if there was already a

Start-Sleep -Seconds 60

I will change code to map drive directly within odrive agent startup script. This should avoid letting Windows Task Manager decide when to start things scheduled “At system startup”.


1 Like

Great! Thanks for the follow-up @D_Sec