Not syncing to the cloud

I put some files in the ODRIVE folder. It is not syncing to my amazon cloud.

Do I need to manually do something? Shouldn’t it sync automatically each time I put a file in the folder?

I manually did a sync, still no luck


Can you tell me what you see when you click on the odrive tray icon (or take a screenshot)? I am curious if there are any items listed in “Syncing”, “Waiting”, or “Not Allowed”. If there are other things currently syncing, you will see a delay when adding new files, as the other operations will need to clear first.

I do not see any of those things you mentioned. That is whats confusing. Here is image

anyone? Nothing syncs for me…

Can you try something for me? I noticed that the odrive folder looks to have been renamed to “ODrive”. It is possible that the client is confused with the case change of the odrive folder (it is very specific with that particular folder). Can you rename it back to all lowercase?


I renamed the folder to lowercase. I also noticed the folder which contains the new files i added, does not have a blue CHECKMARK in the files INSIDE the folder. The folder itself has the blue checkmark, just not files inside. I want all subdirectories synced. Do I need to do something? I assumed anything in the odrive folder is synced always.

After renaming the odrive folder, please restart odrive. If things are still not syncing after that, please submit a diagnostic report from the odrive tray menu.

odrive will automatically sync anything put into its folder stucture as long as it is setup properly.

done. thanks… if anyone else can think of something, please let me know.

It looks like things are syncing now. If you are seeing that something is still not syncing, can you tell me what the path and name of the item is and send one more diagnostic?



It still is not syncing.

I added this new folder:

E:\ODrive\Amazon Cloud Drive\PHOTOS\2016 - Mixed

There is a folder (E:/odrive/Amazon Cloud Drive/PHOTOS/Recovery) that is producing a filesystem exception for permissions. Can you try altering the permissions on that folder so that odrive has proper access? I believe this could be preventing odrive from successfully processing the PHOTOS folder.


Bingo! That was the problem. I deleted the recovery folder. Thanks so much!!!

1 Like