Not allowed files when trying to sync to IIS Webdav

Hi, I have setup my IIS server with Webdav, SSL and digest authentication. This all works fine and syncs files to the client. If I add a file to the folder it will not sync back up to the server. It stays in the Not Allowed list. Why is this?

Hi @tim.adams,
When you click on one of the files listed in “Not allowed”, what does it give for the reason?

Can you send a diagnostic from the odrive tray menu so I can take a look?

Thanks!

I have just clicked on the send diagnostics. The reason is “The item does not exist on the WebDAV server.”

You get the option to delete your change or cancel.

Hi @tim.adams,
The current items in not allowed appear to be illegal character issues with OneDrive for Business, which has really strict rules on allowed characters. In this case it looks to be the “%” character.

More on their restrictions here: https://support.office.com/en-us/article/Invalid-characters-in-file-or-folder-names-or-invalid-file-types-in-OneDrive-for-Business-64883a5d-228e-48f5-b3d2-eb39e07630fa

For WebDAV, the server is throwing an exception, but it is generic. Can you tell me the name of the file(s) that are not able to sync? There may be an issue with mime typing or special characters that needs to be adjusted on the WebDAV server side. More on that here:


You should be able to find the WebDAV logfiles in C:\inetpub\logs\LogFiles\W3SVC1. These may give us some better info on what is happening too.

Yeah I looked at the MIME types before I added this post. I don’t think this is the issue. I have setup two servers with WEBDAV using two different odrive accounts and have the same issue. Any file I drop into the odrive Webdav folder does not sync back to the server. I have sent the diagnostics again. The files that wont sync are VMware-viclient-all-6.0.0-dev.exe and JRT.txt. I have deleted the onedrive failed files.

I have also tried uploading using the web page (https://www.odrive.com/browse/Folders) also and this fails. It says unable to upload. Please retry.

If I map the drive in windows via Webdav. This works. I can save files to the same folder on the server.
Logs on the server show the following:

2016-11-18 22:25:44 192.168.100.15 PUT /folders/JRT.txt - 4433 - 109.234.**** python-requests/2.9.1 - 401 0 5 281
2016-11-18 22:25:45 192.168.100.15 PUT /folders/JRT.txt - 4433 - 109.234.**** python-requests/2.9.1 - 401 1 2148074256 140
2016-11-18 22:25:45 192.168.100.15 PUT /folders/VMware-viclient-all-6.0.0-dev.exe - 4433 - 109.234.**** python-requests/2.9.1 - 401 0 5 62
2016-11-18 22:25:45 192.168.100.15 PUT /folders/VMware-viclient-all-6.0.0-dev.exe - 4433 - 109.234.**** python-requests/2.9.1 - 404 13 0 203

I have stared (**** ) out some of the IPaddress’s.

Any ideas?

Hi @tim.adams,
The 401 error indicates that it does not like the credentials being used or there is a permissions problem. Are you able to download files? If so, that would point to a write permissions issue on the folder. I’m not sure why it would not have the same issue on Windows built-in WebDAV, though.

You mentioned using digest authentication. Are you using that against AD?

Yes I am using this against AD. The user is in a group that has modify permissions. Yes we can read and download files just not write anything to the folder via Odrive. I have enabled Anonymous Digest and windows auth in IIS on the Webdav folder. In webdav settings it is set to All Content, All Users with read source and write. Do I need to set some other permissions somewhere else?

Found this also. If this helps
https://support.microsoft.com/en-us/kb/2021641

As a test I have disabled all auth types other than Digest on the webdav folder. This allows me to login but still have the same 401 in the logs.

Hi @tim.adams,
With only digest auth enabled, are you still able to add files via the Windows built-in WebDAV functionality? As a baseline test, I sometimes use Cyberduck as a way to validate “standard” WebDAV functionality. Would you be able to see if Cyberduck gives the same error?

Additionally, if you can PM me some credentials, I can run some tests from my end to see if there is anything I can discover about your setup.

Tried Cyberduck and cannot connect with digest auth enabled. Also Windows built in doesn’t work properly. Lets you create a file but not edit it. Cannot open an exel file via Built in windows webdav. Not sure what the issue is. The error from cyberduck is unexpected responce (500 Internal Server Error). Cannot give you credentials at the moment.

A while back I had setup a IIS WebDAV server with digest auth against AD, using network shares as the WebDAV folder targets. It was a complex setup and I remember there were a few caveats. Unfortunately I can’t remember the details of the caveats. Permissions was a bit sticky, though, with permissions needing to be granted in multiple locations, including specifying delegated permissions.

I would like to try the setup again, taking extensive notes this time, but its a time investment I can’t make at the moment :frowning:

If you are able to provide a test account, I may be able to identify something helpful, so just let me know when/if that becomes a possibility.

Thanks Tony. Appreciate your support. I will try and get some details to you if possible. I have also updated to version 6045 today to see if this helps.

Also is there any other alternative way to share folders using the odrive client on a Server 2012 R2?

For alternatives you could use IIS FTP.

Also, I’m not sure if this is an option, but did you try “Basic” authentication for WebDAV?

Just thought I would update you. I tried basic and this did not work either. Also tried FTP and could not get this to work. So tried SFTP using Bitvise SSHServer. This now works.
Thanks for your help.

Thanks for the update @tim.adams. I wish we knew what the issue was there. It seems like some sort of obscure permissions problem. In any case, I am glad you’ve got a solution that works for you now.