New System, Sync File Conflicts


i have a new laptop, and installed odrive, and i downloaded some of my synched files to work on. that went all well and good!

however, now when i resave any of these files, odrive is putting them in a ‘waiting’ state, and creating files such as File Name(conflict).ext.

so it seems to be confused whether the files on the cloud (i’m using backblaze/b2) are more recent than the files i (re)saved today. i’ve been without a computer for going on 3 weeks (!!!), so the files on the cloud are definitely older than the ones from today!

is there anything i can do to resolve this? thanks!

Hi @BLR,
The sync activity log should provide some additional information about how odrive is seeing these items and why it is determining that they are conflicts.

To access the sync activity log:


sync activity log



Once open (as main.log), please save it to your Desktop and then you can send that to me directly by clicking on my name and selecting “Message”.

sorry for the delay, i have been ignoring this problem while trying to catch up on my work anyway…
but it is starting to really interfere with my work.

i’ll send you the log file now. help me obi-wan!

i know i am working on files and sometimes i re-save them after VERY short intervals. it used to be that if i tried to resave a file odrive was working on, the program (photoshop or blender) would pop up with an error about not being able to write to the file. that was good, i could wait a couple of seconds and try again.

NOW, however, odrive is just changing the file name every time i try to save it, Without Telling Me! i wasted 40 minutes trying to adjust and resave a file in photoshop, then swapping to another program that would pick up the file change and re-display it… and not seeing any significant changes! or ZERO changes, because the file i was saving to wasn’t THAT file!

this morning, i tried to open the latest (conflict 7) file in my program. my program instantly crashed.

also, the original file (the non “conflict” named one) was no longer on my computer hard drive, but had been changed to a .cloud file. why was it removed from my hard drive? odrive has never done that before!

is this a new method to handle people re-saving a file too soon? cuz i don’t like it :frowning:

Hi @BLR,
Can you exit odrive and install the latest version from here?

There was a fix made for B2 uploads that I think will resolve the issues you are seeing.


thank you so much, tony!! you are a rock! :slight_smile:

1 Like

Sure thing @BLR ! Just let us know if anything else comes up.