New folders not synching 'No Options Available'

And everything was going so well…

I’ve got a bunch of new folders that aren’t being picked up or synched by oDrive. When I right click on them, it says ‘No options available’ in the context menu.

I’ve run the CLI commands, and there’s nothing uploading or waiting. Any help to get these folders to synch?

1 Like

I had the same issue for months on one of my laptops after a Win 10 update. Other laptops, same update were fine. Went through various trouble shooting with Odrive support over a couple of weeks and nothing worked.

Eventually I gave up on that device and ran Resilio Sync instead.

Recently I had other issues with that laptop and ended up having to completely reinstall Windows 10. I decided to give Odrive a fresh install as well and BOOM! everything working great. I hate to say it but if you’re on Windows you may need to do an OS refresh or reinstall in order to fix Odrive.

Here is some of the feedback/ troubleshooting steps they gave me: New folders not synching 'No Options Available'

1 Like

Hi @smblythe,
When you get a chance, can you send over a diagnostic from the odrive menu and give me a couple of paths that are exhibiting this behavior?

Are you able to upload files in other areas, or is nothing uploading at all?
What about downloading?

Hey @Tony

I’ve done a bit more digging on the forums, and I suspect that it may be because I have a large upload operation going on on a separate device I have running (currently synching an external drive). Am I right in understanding that if there are large uploads going on, that it can cause these issues with the synch on other devices (using the same account) as well?

Hi @smblythe,
This can be the case if the bulk operation is on the same device, but it shouldn’t have this effect if its happening on a different device.

“No options” usually indicates that odrive hasn’t cataloged the file/folder yet, or it means that the file/folder has a name that is ignored:

Interesting. It’s still not finding the new folder I added. It’s just called 2017, so shouldn’t be an issue there.

Any way to force a refresh on the folder so oDrive catalogues it correctly?

@Tony I’ve just send over the diagnostics. Thanks for taking a look!

The path of the folders doing this is:

Amazon Cloud Drive > Digital > 2017

The 2017 folder has the context options, but it isn’t being uploaded. None of the subdirectories or files have the context menu, and none have uploaded.

I think I’ve managed to get it working. Creating a new folder didn’t seem to want to work, and neither did renaming the folder. So… I moved some of the sub-directories out from 2017 into the Digital folder, and they began to Sync. Once they had synched, I then created a new folder and moved them into that - then renamed it 2017. Now it seems to work.

Looks like the original 2017 folder’s connection to oDrive got borked somehow. Weird.

I appreciate the update @smblythe.

I took a look at the diagnostic and it looks like odrive was bombing out when trying to scan that 2017 folder because of what looks like a self-referencing symlink. The path it was hitting before bombing was:
2017/3. March 2017/Al, Liz, Grace, and stuff/res/res/res/res/res/res/res/res/res/res/res/res/res/res/res/res/res/res/res/res/res/res/res/res/res/res/res/res/res/res/res/res/res/res/res/res/res/res/res/res/res/res/res/res/res/res/res/res/res/res/res/res/res/res/res/res/res/res/res/res/res/res/res/res/res/res/res/res/res/res/res/res/res/res/res/res/res/res/res/res/res/res/res/res/res/res/res/res/res/res/res/res/res/res/res/res/res/res/res/res/res/res/res/res/res/res/res/res/res/res/res/res/res/res/res/res/res/res/res/res/res/res/res/res/res/res/res/res/res/res/res/res/res/res/res/res/res/res/res/res/res/res/res/res/res/res/res/res/res/res/res/res/res/res/res/res/res/res/res/res/res/res/res/res/res/res/res/res/res/res/res/res/res/res/res/res/res/res/res/res/res/res/res/res/res/res/res/res/res/res/res/res/res/res/res/res/res/res/res/res/res/res/res/res/res/res/res/res/res/res/res/res/res/res/res/res/res/res/res/res/res/res/res/res/res/res/res/res

When you moved things around it may have replaced that symlink with a real folder, or created some other change that removed the issue.

Glad its working now!

1 Like

Ahhhhh thanks. Looks like that recursive folder was still present, and oDrive just hadn’t gotten to it yet, which gave the illusion of it working. I’ve removed it now, so should be good!

Is there any way for us to view the diagnostics for future reference?

Hi @smblythe,
Thanks for the update. The next generation of odrive will have better visibility into stuff like this. Unfortunately, right now, these types of errors are buried.

1 Like