Move folder to external drive

Tried it several times in Windows 10. Does not work at all, just does nothing.

I’m in the premium trial.

Hi @andreas,

Sorry for the inconvenience, to better understand the issue, would you like to elaborate the problem you are experiencing with moving odrive folder to an external HDD? if you are getting an error, please share the screenshot of the message.

Btw, sometimes permission errors on external HDD may also lead to failure of the move operation. Do you have sufficient write permissions on HDD and are able to directly create a test folder?


Yes, I have write access.

Like I said, nothing happens, not even an error message. The same thing on my mac works flawless.

This is strange, I have couple of things to confirm:

  1. Do other tray menu options work?
  2. Is “Move odrive folder” is the only option having the mentioned issue?
  3. Would you like to send snapshot of your odrive tray menu?
  4. Click on “Move odrive folder” from tray menu, and then send "Diagnostic report. I would like to see if there is any error / exception being raised in logs.


The action should work, but keep in mind that moving the odrive folder to an external volume is not officially supported, as stated here:

For clarification, is this a network drive or an external hard drive? You cannot move to a UNC path (accessing network drives without mounting them explicitly). The external volume would need to have a drive letter to anchor to.

yes, it’s an external drive with a letter.

the tray action works, I get the dialog to select the place, but when I choose it, the folder won’t get moved.

I have this exact same problem and am also on windows 10.

I’ll try to find some time to take a look at this.

It is something I expect to work, but, as stated above, this is not a use case we officially support. The reason being that it can complicate sync substantially and create issues with reflection/pick-up of changes, permissions, CPU heat, disk churn, inaccurate scans, user feedback lag, and other problems.

Our “sync to odrive” feature allows you to sync specific areas on external volumes without needing to move the entire odrive folder to an external volume. Have you tried that feature yet?

Thanks, wasn’t aware of that feature, matches my use case even better.
Unfortunately my premium trial has run out of time, so I can’t test.

We offer a full refund on the Premium subscription if you cancel within 30 days if you want to try it out.

Using Windows 10, I have been able to move the odrive folder to an external drive. However, the “sync to odrive” feature does not work for any folder. Is this because I am still on the trial premium version ?

sync to odrive should work just fine if you are on a trial or have Premium. Since your last message was quite some time ago, I would not expect your trial to be active anymore. Are you not seeing the “sync to odrive” feature at all, or are you seeing it but it is giving an error?

Also, please keep in mind that moving the entire odrive folder to an external drive is not something we support or test.

Thanks or the quick reply, Tony. To clarify: I am not the original poster and am still on Premium trial since I just signed up yesterday. I have only added to this thread because I have experienced the same issue.

When I right click on any folder using Explorer, I do see the “sync to odrive” option, but choosing it does not do anything. I believe I need clarification on the following paragraph found here:

> You browse to the desired storage location inside odrive and create a new folder. You create a new folder by clicking on the “+” folder icon. Be sure that you actually click “enter” or “return” on your keyboard, to create the path to the new folder. After you enter the path, click “Okay”.

I am lost as to where to do this. Do I go to the (hidden) odrive icon in the taskbar ? There is a “Sync to odrive” entry, but choosing it shows only a greyed out “No sync folders registered”.

On the positive side, I have dropped files in the odrive folder on the external HDD (with drive letter) and have verified that they are being uploaded to AD. While this may not be officially supported, it is working for me in Windows 10. As you had pointed out above, it does not work for a network drive, though.

Hi @andreas.glatz,
Apologies, I read both you and andreas as being the same person.

So, when you click on “sync to odrive” it should pop a browser window that allows you to select your “sync to odrive” destination. Maybe you can try closing all browsers and then try again and see if it pops?

Thank you, that worked:

A new folder will be created with the same name as the folder on your computer (unless one already exists or if the destination folder itself has the same name).

Great! Thanks for the update.