maxConcurrentUploads being ignored

I am a premium user and have set the maxConcurrentUploads to the value 2. In fact all of the relevant setting are set to 2 as follows:
“initialUploadBatchSize”: 2,
“maxConcurrentDownloads”: 2,
“maxConcurrentJobs”: 2,
“maxConcurrentUploads”: 2,
However, odrive client seems to ignore these settings and is uploading up to 4 files at a time per this screenshot:

I know the odrive_user_premium_conf file was read because I see in the diagnostics that my custom blacklist file is shown.

I have attached my odrive_user_premium_conf.txt file also

odrive_user_premium_conf.txt (458 Bytes)

Diagnostics generated and sent at 08:59 Irish time today.


Further to the above, I believe I may need to interpret this statement from the odrive usage instructions differently:
"This setting represents the maximum number of “jobs” that can run concurrently. A job is generally associated with a upload or download action within a single mount (sync to odrive) or folder heiracrchy. "

I read it as being that a job is one sync to odrive mount OR OTHERWISE a folder (within the odrive home folder). I probably need to assume that a job can also be a folder within a single odrive mount. That would explain the behaviour as the four files being uploaded consisted of 2 files each from 2 directories within the sync to odrive mount.
If I want only two concurrent uploads, then , I guess I need to set my maxConcurrentJobs to 1 and leave maxConcurrentUploads at 2. Would that be correct?


Hey @sean,
Yeah this part is a bit confusing. Due to the multi-threaded nature of odrive’s general scanning and processing you can end up having multiple “jobs” that are completely independent of each other if they occur in separate folder structures.

As you reasoned, to set a hard limit globally, you would want to limit the number of jobs to 1.

1 Like

OK. Thanks for the reply @Tony

1 Like