Link Webdav to Synology NAS not possible?

I try to link via WebDav my Synology NAS.
Access via Webdav/https on port 5006 is working (from the internet) via “Total Commander” => so the NAS (+ Router) are setup correctly. I did not have to use a certificate for this.

When I try to link storage via WebDAV in oDrive (using exactly the same address:port, usernam and password that work in Total commander), I get either an error “Cannot connect to WebDAV server. Check your internet connection and try again.” (with option “require valis ssl certificate” disabled) or I get an error “Invalid SSL certificate. Name Mismatch.” (with option “require valid ssl certificate” enabled).
I checked the certificate on the synology NAS: name seems correct (i.e. that name I use for the connection), that cert is configured to be used for WebDAV and the certificate is (still) valid…

Anyone any idea? I prefer to have oDrive instead of the “heavy” Synology Drive client to be able to share my documents between my wife’s and mine laptop…

Thanks ,
Jörg Hofmann (Germany)

Hi @hofmannj,
I don’t have a Synology NAS to test with, but if you can provide a test account on your internet-accessible NAS, I can try to see what the issue is with linking.

Hi Tony - thanks - will do this in the evening/after work (now 8:00 in Germany)… hope you can find it.
Probably I need 1h+ to figure out how to setup another user on the NAS and bind it to a certain folder/over Webdav (and of course trying first that with a webDAv client this new account works :slight_smile: . I’ll post you…

Hi Tony, the NAS is prepared - if you send me an email ( I’ll send you the path, the user and the password…
As you can see in the attachments (last picture in next post as I’m not allowed to post more than 2 media :frowning: ), access over WebDAV (via mobile) using Total commander “works like a charm” - just the path, user & password… I hope you can find it why odrive doesn’t want to link…


… and last picture:

Hi @hofmannj,
I sent you a private message. Can you take a look, when you get a chance?

Hey @hofmannj,
I took a look at this. What is strange is that it works fine when debugging locally on my system, but not once it gets pushed to our backend.

It looks like it has something to do with the name resolution. It is taking a long time (~30 seconds). It is not clear why, at this point.

Immediate workaround:
You can use the IP address of your NAS instead of the hostname. You will need to disable certificate validation since the names will not match.

I have added a few fixes for the next release. These will address the previous certificate validation error you were seeing and will also allow you to continue connecting even if our backend has an issue. The latter fix will allow you to use the desktop client, which does not exhibit the same timeout issue I am seeing on the backend.

I’ll keep poking around, but this is a tricky one. I am only seeing this behavior for your particular host… it is really odd.

Hi Tony,
thanks - I already started doubting that I screwed up something (I tried this now several times for months).

Using the IP address is not really a help (DT retail subscribers like me get a new IP on each new DSL connection)… but I can wait for the fix you mentioned. Any idea about “when” this may be available (your’re doing Scrum/agile? 2-4 weeks?).

Regarding “behavior for your particular host”: that is a pretty normal (standard) Synology NAS 418 (there are >> 10k of then all over the world I’m pretty sure) with the latest Synology OS (DSM 7 - I had the same behaviour with DSM 6)… so the the fix would probably help a lot more peaople…

Hi @hofmannj,
I would say 1-2 weeks is realistic for this. I’ll let you know once it is out.

Hi @hofmannj,
This was pushed out to production. Can you try linking again?

Hi Tony,

tried both ways (with/without valid SSL cert) - same as before:

  • with ssl check => after about 1 min I get “Invalid SSL certificate. Name Mismatch.
  • without SSL check => took about 2.5 mins, then error message “Cannot connect to WebDAV server. Check your internet connection and try again

Tied this both with the user I gave you as well as “my” user…


Thanks @hofmannj. I am checking into it. We may have missed something.

If it may help => we can do a teamviewer-session & you could check on my laptop… just in case.

Hey @hofmannj,
Give it a try now.

The web access is very slow, but you should be able to link (while verifying the SSL cert) by selecting “Continue Anyway”. Browsing via the web is possible but slow. Desktop client access should be just fine, though.

Works now! Great!
(I’m so stupid - I just didn’t recognize before the “link anyway”.)
And the speed in the windows client is really nice/more than sufficient - thanks.
Can be marked as “solved” imho.


1 Like