Labels disappeared only one that shows is "Junk E-Mail"

I have been using odrive for almost two months now, and it is exactly what I needed for the large amount of attachments I need to open every morning. I have 14 emails with one attachment each that I receive every morning. These are separated into two labels. I used to be able to go in to my odrive file and go into labels and my many labels were there in separate folders. Now when I go in there the only folder is called “Junk E-Mail”. I’ve uninstalled and reinstalled the program and it still shows the same thing. I’m not sure what happened between Tuesday when it worked as it always had and Thursday when it didn’t but I can’t seem to find those folders anywhere. When I look on the browser I can see my labels. I tried to add a file and it said “Cannot upload to Gmail/Labels/Inbox/Advance CPS/Reports/Maple. This folder is read only.” I cannot reproduce the message on my computer, but when I first noticed the problem on Thursday, I was getting a similar message. At that point the labels were there but were “not allowed”. I’m not sure what is going on, or if I did something on my side that has messed this up, but it was perfect while it was working. Please let me know what to do to fix this issue so I can continue to use your product as I originally did. Thank you for your help in advance! :slight_smile:

Hi there,

That sounds like a strange problem, but I’m glad you still can see your folders on the browser. That means nothing is actually missing and it could possibly just be a strange glitch.

Since you’re been using odrive for a while, I believe you have the unsync capability. Can you try right-clicking on the label folder, and then after that re-opening it? This will cause odrive to re-sync that folder, and will fix any temporary problems.

If that doesn’t work, could you please send diagnostics? It is an option available through the system tray. Then I’ll take a more closer look.

When I right-click the system tray icon I have the option to Pause sync, no option for unsync. I went into the folder and I signed up for the 7 day trial to unsync, then tried to sync them again. Still no folders in my Labels folder except Junk E-Mail. I sent a diagnostics report just now, hopefully you’ll be able to see what’s going on. I wasn’t at the office on Wednesday, but it definitely was working normally on Tuesday, and not when I got back on Thursday. Nobody else has access to this computer while I’m away, so it must have either glitched out, or I did something wrong. Thank you for looking in to it.

Hi Rachel,
You will need to right-click on the “labels” folder inside your Gmail link and then select “unsync”. Do you see that option? If it is not there, but give n option for stop sync, do that first, then unsync should show up as an option.

Your diagnostics report reports look clean to me. However, it seems like you’re using an account that was just created today. Do you perhaps have more than one Gmail/Google account, and logged in with a different one? Try going to the system tray icon->Authorized User->Deauthorize, and it should tell you which account you’re logged in with.

Yes, I thought maybe there was something wrong with my account so I deleted my old account, then made a new one with the same email. I hit unsync, and now when I go back in there I don’t see any folders. Then I hit Sync again, and checked the box that says include subfolders, and have the slider set to everything. When I go back in after syncing again, I still only see Junk E-Mail

On this account, are the label folders showing up on the web browser ( for you?

Yes they are, and the same message is popping up when I try to add a file or folder about Gmail folders being read-only.

Hi @Rachel_Borofsky,
Gmail is a read-only link, which is why you are getting that error when trying to add something to it. Google Drive would need to be linked if you want to store new documents in the cloud.

I want to try an experiment to see what the results are in your desktop client. Can you create an odrive Space against your Labels folder and invite yourself to it (invite your goole e-mail)?

Once you create the Space and invite yourself, you will get an e-mail to join. Click on the link and confirm. Then expand the new space folder in your odrive directory on your computer.

Do you see the labels now?

I don’t see ‘Spaces’ in my account, the only options are ‘Links’ and ‘Sharing’.

I did just link my Drive to my account as well, though not sure if it will help anything.

Sorry for the confusion. You can enable spaces here:

I tried sharing the labels as a space and it is still showing Junk E-Mail as my only label.

I’m going to try to share a space for a single label and see what happens.

I made a space for one of the labels I need, but it isn’t showing all of the files that should be there. The same files that are showing also show if I look for these reports by contacts. It’s showing one from the end of February and then 4/7 of the reports I should see for today, and 4/7 of the reports from last Friday. I used to be able to go back to mid-January or at the latest beginning of February and see all 7 reports from each day.
It shows that the folders are synced, but it doesn’t seem to be the case.

Appreciate all the details. We’ve identified a fix and it is being worked on.

This fix is now in our latest version, which you can download from