Issue in sync for subfolders in GCS

I have the following pattern parent_dir/foo/bar/custom/test.csv and I can`t sync at all.
I am able to sync all the other folders with a pattern of parent_dir/foo/test.csv or parent_dir/test.csv
but not this one.
Tried both auto sync and manual

Hi there,

Were you linking to Google Cloud Storage with existing data? If so, can you make sure you linked using the SIMPLE '/' DELIMITED option as shown in the screenshot below?

If you did link with Simple ‘/’ Delimited, can you describe what you’re seeing when you see “I can’t sync at all”? Do you mean that you just don’t see those files which match the parent_dir/foo/bar/custom/test.csv pattern? Or do you see them fine but you get some sort of error when you right-click --> sync on them? (If so, what error? Perhaps you can reproduce the problem and then immediately go to the tray icon menu and select “Send diagnostics”).


Hello Jeff,

Yes the SIMPLE ‘/’ DELIMITED option was selected.

Regarding syncing the issue occurs only in the internal files. So if I sync parent_dir (with option include directories and subfolders) all directories are ok, but the csv files are not.

There is no error shown in the UI.

The only difference between these csv files and all the other is that the GCS has marked them as “text/csv” and “application/octet-stream”

Could you have a look and I`ll try to reproduce the issue and select the Send diagnostics


I`ve tried with Send diagnostics. Have a look

Hi @alexandros,
I took a quick look at the diagnostic. I am not sure which files you are looking at, specifically, so it would help if you can provide those paths.

However, I do see some illegal path exceptions on csv files that have a “:” character in the name. This character is not allowed in the Windows filesystem, so it can’t be brought down. You would need to remove any illegal characters to download those files.