Install using MS Intune Endpoint Manager

Anybody have any info on how to deploy ODrive using MS Intune Endoint Manager to Azure joined Win 10 devices please?
Not having any luck with the scripts on the docs page.

Thanks Trev

Hi @trevor.farquharson,
I don’t have experience MS Intune, unfortunately, but can you tell me about the approach you are taking? I’ll see how we can help.

Hi @Tony
First off we tried installing using a batch file and a Powershell script. Same way we install other programs.
The batch file calls the PS script with elevated permissions.
This is whats in the Batch file, it has the -ep bypass for bypassing the Execution Policy:
Powershell -ep bypass -file C:\InputFolder\ODrive\ODrivesyncInstall.ps1

This is whats in the PS script:
msiexec /i C:\InputFolder\ODrive\odrivesync7032.exe

When we run this we get an Windows Installer error:
This installation package could not be opened. Contact the application vendor to verify that this is a valid Windows Installer package.

HELP! :slightly_smiling_face:

Cheers Trev

Hi @trevor.farquharson,
Are you able to run the installer, by itself?

Here is a version of our installer that will not run after install. It is intended for true silent installs via bulk deployment

So, in your PS script, can you take the installer from above and run it like this:
C:\InputFolder\ODrive\odrive.7032-NL.exe /quiet /log "odrive_install_log.log"

1 Like

Hi @Tony
Before i read your reply, We changed the PS script to this:
Start-Process C:\InputFolder\ODrive\odrivesync7032.exe -ArgumentList “/q”
And now it asks for an Admin account creds to install. Which is not totally unexpected since we are testing still.

Now back to your reply. I have downloaded the new file and changed the PS script. Still comes up with the UAC prompt. Log file created too.

Hi @trevor.farquharson,
The installer will need elevation for installing to “Program Files” and to install/configure the Explorer extensions, which is why you are seeing the UAC prompt.

Does Intune allow you to run the initial batch script elevated (like running in the system context)?

I ran a quick test using the flow you described above, but with the initial cmd prompt for the .bat running in the system context and it installed without a UAC prompt.

Hi @Tony
So ran the bat file with elevated cmd and it didn’t pop up the UAC prompt. Progress!!
In the Control Panel - Programs and Features the ODrive looks installed.
Did not prompt to sign into ODrive though via web browser though. Default browser was old Edge. yuck!
No ODrive folder in the C:\Users%UserName% folder.
No ODrive icon on the task bar

Have rebooted and changed default browser to Chrome.
Uninstalling via Control Panel and it popped up with the Get Started setup process. Finished uninstalling process.

Have tried installing again locally via the cmd prompt and got log files, Same result, looks installed
Did not prompt to sign into ODrive though via web browser though. Default is Chrome.
No ODrive folder in the C:\Users%UserName% folder.
No ODrive icon on the task bar

Yes installing via Intune EndPoint Manager can install with either system or user. Will need user for this one.

Do you want the log files?

Cheers Trev

odrive_install_log.log (8.4 KB) odrive_install_log_000_Odrive_x64.exe.log (192.0 KB)
Install log files.

Bat file script:
xcopy C:\InputFolder\ODrive C:\Temp\ODrive /i /q /y
Powershell -ep bypass -file C:\Temp\ODrive\ODrivesyncInstall.ps1

PS script:
C:\Temp\ODrive\odrive.7032-NL.exe /quiet /log “C:\Temp\ODrive\odrive_install_log.log”

I will attempt to install via Intune.

What is the Uninstall path or command?

Cheers Trev

Hi @trevor.farquharson,
Thanks for the quick responses!

  1. The app won’t launch automatically after install with the -NL (no launch) build, so the user would need to launch it manually. The reason for not having it launch after install in a silent deployment scenario is that it would launch under the installing user (which may be System) instead of the logged-in user. The app will also start automatically on user login, once installed.

    I think it is probably what you saw when you restarted and performed the uninstall. The application started up automatically after login and the window popped-up as you were attempting to uninstall it, coincidentally.

  2. You won’t see a C:\Users[username here]\odrive folder until you sign-in to odrive.

  3. You can use the installer to uninstall, also:
    C:\Temp\ODrive\odrive.7032-NL.exe /quiet /uninstall

Just let me know if you have any questions on the above items.

And thank you for the quick responses.

OK so that’s working now via a local install.
We clicked on the ODrive icon in the Start Menu and it kicked off the login process. :slight_smile:

Is there a file/folder or registry entry we can reference when we have to detect if the program is installed? Part of the Intune process needs this when setting up the installation package.

Cheers Trev

Hi @trevor.farquharson,
When odrive is installed, you should be able to easily tell by looking for the following registry entry: HKEY_LOCAL_MACHINE\SOFTWARE\odrive

Hi @Tony
No luck with installing via Intune EndPoint Manager.

Is ODrive going to be coming out with an MSI installer version of this program?

Cheers Trev

Hi @trevor.farquharson,
I’ll take a look at what can be done here. Where did you end up hitting a snag? Was it the UAC prompt?

Hi @Tony
Just lots of things getting caught up. Failing with no useful error. Even trying to deploy via GPO in onPrem AD is causing us a headache. Software just seems install easier when in an MSI


Hi @trevor.farquharson,
Can you give this a shot, when you get a chance?

This build hasn’t gone through our full QA process, but I wanted to give you something to test and verify ASAP.

Hi @Tony
That msi file has installed :slight_smile:
Will do more testing on Monday with a user account that has Procore access.
Didn’t get an option to install with User context, only System

1 Like

Perfect! Thanks for trying that @trevor.farquharson.

I think the User option isn’t available because the installer needs to be elevated.

Hi @Tony
I have noticed when uninstalling, that the folder ODrive folder in the C:\Program Files\ does not get uninstalled.


Hi @Tony
I did a full test of install to signing in and it appears to all work as expected.
Installed via Intune and can Uninstall as well via Intune.
Click the ODrive icon and it takes you to the login page to select which account, Procore or the other options. Click Yes to create an ODrive account and then Next Next Next.
Has created a .odrive folder and ODrive folder in the Users profile.
All the options from the link in the Task Bar.

Will test via GPO deployment next.

Cheers Trev

1 Like

Thanks @trevor.farquharson . We’ll take a look at this.