How to stop Odrive from removing local files after a sync is complete?

I made a mistake and removed all other cloud programs from my work PC and started using odrive in their place.

Now, I have discovered that Amazon unlimited storage is going away. So, I thought I would copy all my files to a new drive for backup before figuring out my new cloud solution.

Once I started digging deep (5-6 folders deep or more) into my “backed up” files I noticed that odrive has been removing all of my files. These are huge files. I have projects over 200gb at times that I need to be able to work with and can’t wait for them to be re-downloaded constantly.

The root folder “odrive” as well as several futher down have been manually selected to sync with the check box marked to keep everything synced.

What do I need to do to stop odrive from removing files?

I need to get all my files before Amazon deletes everything and I have nearly 7tb worth of files. It would not be pleasant to try and download everything. Plus, if I use Amazon drive again right now, odrive has replaced all of my work with it’s propriety files which are worthless for my backups.


Thank you thank you to anyone that can help.

I am currently just trying to go into all my files and constantly open the ones that are available to make sure they aren’t deleted.

Hi @wraparizona,
Can you clarify what you mean by “odrive has been removing all of my files”? odrive won’t remove any local files unless:

1- the files have first been removed from the remote storage (remote delete) and odrive syncs that change.
2- If the user unsyncs the local files or has auto-unsync enabled so that the files are automatically unsynced. Unlike #1, this will only remove the files locally, replacing them with placeholders and leaving the content in the cloud.

If you have auto-unsync enabled, make sure you disable that in the odrive menu to prevent unsyncing the local content. See here for more details:

1 Like

Thanks. I think I must have chosen un-sync really quickly and then disabled it again at some point.

Thanks for the update @wraparizona. Sounds like you have it sorted now.

1 Like