How do I make only a select amount of files sync when I double click?

We have a lot of projects syncing from Procore to odrive and ultimately to the end users. With these projects come some very large files containing architectural drawings. However, not every user needs access to these drawings as they naturally take up a lot of space. The problem we have been having is that despite the auto-download setting being set to never, when a user clicks on a project folder every file gets downloaded. We have resorted to defaulting everyone to unsync their entire directory every day that way they still have some storage space. This is particularly a problem for some people that work on multiple projects at once.

Hi @troberts,
Thanks for reaching out.

From your description, it sounds like there is a top-level folder sync rule set that is specifying that all items be downloaded.

If you send a diagnostic from the odrive tray menu, we can see what rules are set and then determine what the next steps are:

current_odrive_status.txt (2.3 KB)
Here is my diagnostic file.

Hi @troberts,

Are you experiencing this issue, too? I don’t see any rules set, so I would not expect any auto-downloading on your machine.

Are you able to send a diagnostic from a user that recently experienced this?

I am not experiencing this issue currently, but im the IT rep. Let me reach out to someone thats currently having this issue. The report will be coming from

1 Like

current_odrive_status.txt (15.6 KB)
Here is a copy of the diagnostic report.

Hi @troberts,
Thanks for providing this.

In this user’s case, they have 33 rules that are similar to this one:
C:/Users/cfaulkner/odrive/Procore/MAPP/projects/81111 - UBS Interior Tenant Fit-Out: Download Threshold: inf, Include Subfolders: True

You can see this under the “Folder sync rules” section of the file that you attached. This rule indicates that all files (Download Threshold is set to “inf” for infinite) in all folders under 81111 - UBS Interior Tenant Fit-Out (Subfolders is set to True) will be automatically downloaded when they are newly encountered.

What users can do is modify the rules on their folders to set an upper limit for the files they want auto-downloaded. To do this:

  1. They will right-click on the folder and select “Sync”
  2. Slide the “Download” slider to the desired threshold. This will limit auto-downloads of that selected folder to files that are smaller than the threshold set.
  3. Check the “Include subfolders” box
  4. Check the “Save and apply” box
  5. Click the big silver sync button

While not essential, I also recommend that your users update to our latest version of software. This will give them some enhanced handling and sync optimizations. To do this:

  1. Exit odrive from the odrive tray menu
  2. Download the latest version from here:
  3. Install

Okay, thank you that helps a lot. How would I go about changing those specific rules?

Hi @troberts,
The most straight-forward way would be to have the users go to each project they are working on and go through the right-click->Sync process I listed above on those folders. It will be a bit tedious if they are working on a lot of projects, unfortunately.

At the same time, I would also suggest that the users right-click->Unsync the projects they no longer need immediate access to. This will collapse the structure and remove added unnecessary load on odrive.

Would uninstalling odrive, deleting the config files in the user profile, and then reinstalling work?

Hi @troberts,
Uninstalling and reinstalling will work to reset everything back to a fresh state. The config files in the user profile should already be removed during uninstall, unless the uninstaller is not the same user as the one that runs the software.

If you just want to remove all rules and have the user set them up again when they need them, you can set a rule at the top-level that will clear all of the other rules. to do this:

  • Right-click on the top-level “odrive” folder
  • Slide the slider all the way to the left for “Nothing”
  • Uncheck “Include subfolders”
  • Check “Save and apply…”
  • Click the big silver button