Having a hard time using the odrive Sync Agent

I’m trying to figure out how to properly use the odrive Sync Agent.
I’m going to be referring to this page.
I am currently using the Sync Agent on my linux machine, while on my windows laptop I tend to use the OneDrive official client. I am actually very new to the whole linux system and let’s assume from now on that I am a complete newbie.

Most of the time the agent behaves exactly like I expect it to. I have hower noticed that sometimes doesn’t respond at all.
For example I created a subfolder in one of my OneDrive folder on my windows machine. Said subfolder is synced to the cloud. Howerver I can’t seem to get it to show up on my Linux laptop.
At first I tried running

python “$HOME.odrive-agent\bin\odrive.py” syncstate .

(I was on the folder containing the said subfolder)
It showed that the folder was in fact “Not Synced” which I expected.
I run then

python “$HOME.odrive-agent\bin\odrive.py” refresh .

And got nothing at all.
Rerunning the command

python “$HOME.odrive-agent\bin\odrive.py” syncstate .

this time showed no output at all.
I than tried making sure that the agent was running:

nohup “$HOME/.odrive-agent/bin/odriveagent” > /dev/null 2>&1 &

proceeded to run in various succession the command status, syncstate, refresh both on the folder and the root directory of my odrive mount without getting no outpuut at all.

status however does show something. Namely:

isActivated: True hasSession: False
(genuinely have no idea what it means, can someone explain?)

syncEnabled: True                                              version: prod 939
placeholderThreshold: neverDownload                   autoUnsyncThreshold: never
downloadThrottlingThreshold: unlimited         uploadThrottlingThreshold: normal
autoTrashThreshold: never                                              Mounts: 1
xlThreshold: never                                                    Backups: 0

Sync Requests: 0
Background Requests: 0
Uploads: 0
Downloads: 0
Trash: 0
Waiting: 0
Not Allowed: 0

I tried syncing a placeholder and it said:

Unable to sync folder.cloudf. This file is not inside an odrive folder.

I am pretty sure it is on an odrive folder.
Tried then:

python “$HOME/.odrive-agent/bin/odrive.py” shutdown
nohup “$HOME/.odrive-agent/bin/odriveagent” > /dev/null 2>&1 &

And nothing changed. What am I doing wrong?

Hi @jqjay,
I am taking a look at this. I think the Linux clients may be misidentified after our push last night. I am trying to pinpoint the error and figure out how to address it right now.

Hi @jqjay,
If you run the authenticate command again, to log you back in, it should work as expected now. Apologies for the confusion.

Hi Tony!
Thank you for the prompt reply! You are absoluteley right . After authenticating everything is back to normal.

Great! Thanks for the follow-up @jqjay.