Google Drive Reauthorization Prompt

I am syncing to google drive with three accounts and everything was working great and all of the sudden tonight It will not let me sync to the main account. It keeps saying I need to authorize and then I do on the web and it says authorized and then it will not let me in and says I need to authorize again over and over the other two accounts are working just fine but the main account is experiencing this glitch over and over and over. I have read everything that comes up with a search and to no avail. I have tried un linking all accounts and reconnecting and to no avail. I am very frustrated.

Hi @eddieknoxllc,
After reauthorizing, it can take about 5 minutes to pick up. If you wait 5 minutes it should be okay. You can also try restarting the client.

When you use the odrive web client (, are you able to browse that link?

I just installed odrive yesterday, linked a few Google Drive accounts, Onedrive, and Dropbox… all seemed to work well with both the desktop and web clients. However, now my Windows 10 Laptop (the machine I used to set this up), is making me nuts, everytime I try to explore odrive in windows explorer it just keeps asking me to authorize, I allow it, opens a browser, and the same thing happens over and over again now matter what I try. I have gone to the website, clicked into each folder, and got no authorization issues. What can I do?

EDIT: I also notice that my person Google Drives, now all have TEAM Folders, as if they are part of G-Suite… is that normal? I don’t see team folders normally for those accounts. My work gmail does have team drives, and correctly shows those (but does not work from explorer)

Hi @bigdaddyjsb,
Can you post a screenshot of the error you are seeing on the desktop and send a diagnostic from the odrive menu so I can take a look?

For the TeamDrive folder, the web client will show it, even if you don’t have a Team Drives, but the desktop client should only show it if you have Team Drives. Are you seeing this on the web client or the desktop client?

Hi @bigdaddyjsb,
I just wanted to follow-up on this. I forgot to mention yesterday that renewing the link information can take up to 5 minutes to propagate to the client. This may be what you are seeing after trying to reauthorize.

I have asked that the verbiage be changed on the message box to indicate this and prevent confusion in these situations.

I got the same problem with Google Drive. Reinstalling odrive worked for some minutes, but then the annoying authorization requests began again. Is this still not fixed?
EDIT: Just realized: Is this a Google problem? Are they limiting the number of requests per time period?

Hi @bigdaddyjsb, @ktnx23, @eddieknoxllc,
I have merged some of the separate threads into this one. This is something that seems to have just recently come up for Google Drive, so I’m not sure what the issue is here, yet. Usually Google Drive reauthorization is only needed very rarely.

After reauthorizing , make sure you wait 5 minutes before trying operations again on that link. You do not need to reauthorize more than once, but it can take some time to retrieve the new information.

After you reauthorize, are you able to access the affected link from the odrive web client?

Yes, the issue seems to improve after waiting for some time. No problems now for at least 30 minutes. I work a lot with small text files and if I save too often… Strange that I did not have problems before.

Thanks for the update @ktnx23!

We are improving the language in the next release to make folks aware that they should wait 5 minutes, as well as making it more clear which link need reauthorization.

Google Drive should not need reauth very often, certainly not more than one prompt in the span of a week is expected, so I want to make sure something funky isn’t going on here (like Google changed something in their OAuth handing).

Please let me know if you see this happen again, though. If you do, can you send a diagnostic from the odrive menu along with pinging this thread?

For the link that needed reauth, when did you first link it to odrive?

Will do. But what do you mean by “ping this thread”?

And I linked the account about two years ago. Didn’t change anything about the linked accounts recently.

Thanks @ktnx23.
By ping I just meant post a quick note to this thread.

Ok, it just happened again (without me saving anything! At least as far as I know) and I sent you the diagnostics.

Thanks @ktnx23,
I am investigating.

Is this the same link that had the issue before?
Were you able to reauthorize it again?

Just a heads up, I am also impacted by the constant re-authorization. 3 Google Drive accounts all connected to odrive, getting frequent requests to re-authorize. I’ve tried using the 5-minute wait technique to no avail. I love odrive, so hope this gets resolved soon.


Thanks @pierretapia,
I think we may have found the issue. I’m trying to see if we can get a quick fix out…

1 Like

@pierretapia @ktnx23,
Thanks for your patience. We pushed out a fix for this.

You will need to authorize one more time, but after that it should not prompt you anymore. On the next prompt for authorization, login and then confirm via the odrive web client that you are able to access your link correctly. You will then have to wait a few minutes before the desktop client gets the information (try a restart of the desktop client if it still seems to be having issues after 5 minutes).

1 Like

Thank you, Tony! Things seem to be working well now. Really appreciate the prompt reply.

1 Like

Thank. I will try the next time a reauthorization request comes up.

1 Like