Google Drive - not syncing sub-folders

I have Google Drive folder, that existing (“older”) folders are synced correctly inside it.
However, a new folder created on the computer, or new folders created on GDrive website - do not get synced at all.
Tried restarting ODrive and re-syncing, didn’t help.

My ODrive version: MacOS v7324

Hi @budowski,
Can you send over a diagnostic so that we can take a look?

What is the name and path of a local folder that is not syncing?
What is the name and path of a remote folder that is not syncing?

Thanks for the quick reply - Sent a private message

Hi @budowski,
I can see that odrive is seeing the remote folder you mentioned, although there are pending refreshes for that parent.

I am wondering if the Amazon folder you have still exposed is causing everything to grind to a halt since the API no longer works. We are going to release a new desktop version to gracefully fail now that Amazon has removed the functionality.

  • Can you try moving the Amazon Drive folder out of the odrive folder and then restarting? After that, see if things move forward more quickly.
  • If you are still not seeing what you expect, right-click->refresh on the parent folder and see if that changes anything.
  • If things are still not moving, please send one more diagnostic so I can take a look at things after the above actions.

It worked!
Is there a way to unlink this in general?

1 Like

You can unlink storage accounts here: odrive | Sign in

Click on the ‘V’ to the right of the link you want to remove and select “Unlink”

OK, done - thank you :pray:

1 Like