FTP connection failing

The FTP service I use does not support TLS or SSH, so have correctly (I hope) configured the FTP settings and usinf FileZilla can confirm the password/Account is good …

The O Drive app refuses to connect to the FTP (see picture for settings) with an error of “Cannot browse FTP xxxxxx.co.uk. Please check your network connection or manage your proxy settings.”.
I have tried using “:21” on the end of the ftp server address, again no joy!
Any thoughts or issues you are aware of with this?

I plan to use this with encryption, so any further issues with that ?


Quick update, while the FTP element is still not working, I have been provided some SFTP details to access the server, which do work. The host of the space can see no reason their side for O Drive or FTP generally to have any issues, and point to FileZilla working fine as to that fact.

I would like to understand what either I’ve got wrong or any limitation of O Drive and FTP access, so that other connections can be made without issue, as FTP will be used for other services where SFTP is not available.


Hi @richard.lukins,
Thanks for the update! It sounds like SFTP is a better route since their FTP service didn’t provide any encryption.

For the issue you were seeing, we have a known issue with FTP browsing from the web client on many FTP servers. Did you happen to try it from the desktop client after linking, to see if that worked?