Folders added to Amazon Cloud not appear on desktop client

I am adding folders w/files to my cloud drive via the web, and the folders/files are appearing on the web based odrive file explorer, but not on my desktop folder. I have made sure the sync is complete, and right-clicked the parent folder to sync all files/folder and sub files/folders. Is this an error, or is odrive not designed to update the desktop client with folders added via the web interface?

odrive will sync whatever is in the source to the source folder on your desktop.

Are you seen any Amazon Cloud drive files in your odrive folder?

Yes, I see many odrive folders… online, there are 2 folders that are NOT showing up on my desk top. So I’m guessing it’s an error?

Have you tried to “right-click refresh” in the folder? This will ask odrive to sync that folder again.

Also, has everything synchronized? If there are active files syncs in the same folder, the new folders will not show up until the other items have synchronized.

One more thing, can you confirm the two folders have unique names? If there is more than one file of folder with the same name, only one will appear.

I have right-click refreshed the the folder, and that does not work. All the items have synched, with blue check marks. All of the folders have unique names. I even created a folder on my Amzn Cloud Drive called “test folder” to see if it would show up on my desktop odrive client, and it has not…

To confirm:

  1. you still have two folders in amazon cloud drive that will not show up in the odrive amazon folder
  2. other files and folders show up in odrive amazon folder
  3. you created another folder in amazon cloud drive using the amazon website and that folder also doesn’t appear in odrive amazon folder
  4. you are using Finder or File Explorer to view the folders

Can you try one more thing? Can you see if the missing folders show up on the odrive web client?

  1. yes 2) yes 3) yes 4)yes (finder, OS X)

The missing folders DO show up on the odrive web client , but not on my odrive on my computer. I deleted my test folder and created it again on Amazon Cloud, and it updated on the web client again, but has not shown up on my computer.

Hi @ceilidhmadigan,

The problem you are facing is completely unexpected, odrive app sync changes between desktop and amazon cloud drive. To help us further investigate the described issue; can you please try out the following and provide the result / out-come:

  1. Exit and re-launch odrive app, It will kick off progressive sync which should fetch the missing folders from amazon cloud drive as long as both folders meets the odrive sync rules. Does it resolves your problem? if not then move forward with #2, #3 and #4 below
  2. Provide exact folder names which are not appearing in your desktop clients.
  3. When you right-click --> refresh, do missing folders appear in odrive tray menu (syncing list, waiting list, or not-allowed list)?
  4. Add a test folder into amazon cloud drive link folder from desktop, does it show up in odrive web client / amazon cloud drive web client?

Finally, send diagnostic report, there is an option in odrive tray menu to send the report but make sure to let us know when the report was sent.


I’m having the same issue. When I create a folder on myodrive, or on Amazon Cloud, the folder appears on both myodrive and Amazon Cloud, but doesn’t show up in Finder. I have tried all you options (1-4), as well as removing the program and re-installing. I will be sending in Diagnostics now (10:07 on 05/19/19).

What am I doing wrong?


Hi @moviebuffking,
It looks like the Amazon Cloud Drive folder is in the odrive trash, for some reason. You can see this in the odrive menu under “Trash Bin”.

You can restore this by clicking on the listing, itself, and selecting “Retore” or by selecting “Restore all deletes”