Folder marked as "not allowed" to sync

Hi guys,

I’ve been transferring about 2TB of files from amazon drive on an older hard drive to amazon drive on my new one. Everything worked fine except 1 folder (which contains various sub folders and about 700GB of files) will stay in the “not allowed” tab. I even deleted it completely and copied it again. The folder and subfolders do not contain any illegal character (read through a thread here and the “&” seemed to be the issue).
I really need this folder to sync with Amazon drive as these are my client’s picture files and obviously need to be backed up in the cloud.
What can I do?
I’d appreciate a quick answer, as I’m still on the free plan for another 4 or 5 days and if it won’t sync I don’t see me buying the license, even though odrive is actually nice to use.


Hi @bambi14,
When you click on an item listed in “not allowed” what does the resulting message say? Generally that will tell you the reason why something is not allowed.

Can you send a diagnostic from the odrive menu so we can take a closer look?

Ok, I just sent the diagnostics

Hi @bambi14,
I think the issue for this particular folder (BILDER, right?) is that it was deleted earlier, but the odrive trash wasn’t emptied. Since the odrive trash wasn’t emptied, the folder still exists in the cloud and when the new folder tries to upload it is rejected because the folder already exists.

You should be able to resolve this by emptying the odrive trash from the odrive menu. Just make sure that the items in the trash are ones you definitely want to delete.


Yeah thanks I figured that out – problem was, the folder wasn’t listed in the trash bin. I had to log in to Amazon Drive to delete it there once again and then the folder was removed from “not allowed”. Really, the files I delete appear in the trash bin like hours later or not at all.

Anyway – the majority of my folders and files just won’t start syncing. Some folders - when I right click on them and click sync – give me “unexpected error”. Tried it since 2 days and it still won’t work. Also, folders that have bee uploaded yesterday, don’t show the blue check mark anymore (no matter how often I restart the finder etc). When I click the odrive icon in my status bar, it sometimes doesn’t even react (problem appearing since this morning).

Is there any way I can get the files and folders to sync?

I just resent diagnostics

Now blue checkmarks from main folders show up but the content definitely isn’t synced. Maybe 1 subfolder, but the rest isn’t, and I can’t manually start the sync of these subfolders, cause of the unexpected error.

Hi @bambi14,
The diagnostic shows that odrive is currently very busy syncing items and refreshing content. I see 10 active uploads, 23 active operations (including background tasks), and about 4000 background operations queued up. This will create a lot of overhead and can also cause some temporary errors if you try to add operations (like right-click->sync) on top of what is already active and queued.

My advice would be to let odrive continue its current work until it gets back into an idle state (no items actively syncing and no items in waiting when viewing the odrive menu). I think that some of the behavior you are experiencing may be because of the amount of background activity that is currently taking place.

Once everything calms down let’s take a look at the status and see how things are. I am hoping that everything will resolve out.