Folder doesn’t want to unsync

I unable to unsync a folder. I getting this weird message "Please change the file permission to allow delete"
tyied to synced the entire folder and try to unsync, and I getting this message.
I also dry to Deauthorized and reauthorized Amazone drive without any change
I also tried to change permission for the folder, make the folder as not read only folder, but its keep returning.
I am administrator on this machine, so clearly its not the problem.

How can I resolve it?

Hi @hananel,

That does sound strange.

Can you send us a screenshot of the error window? The error message should tell you which file is read-only. For example:

Can't unsync Folder A. C:\Users\Jeff\odrive\AmazonDrive\Folder A\a.txt is a read-only file or folder that can’t be deleted. Please change the file permission to allow delete.

Notice that the file permission issue in my example above is on a file within the folder that I’m trying to unsync. So I tried unsyncing Folder A but it’s the file a.txt which has read-only permission issues, not the main parent folder itself. Try changing the permission for the offending file (in my example it’s a.txt) .

If that fails, can you try to reproduce the issue again and then immediately sending diagnostics? (Click on the odrive tray menu icon and select Send diagnostics. Select the button to Send Report and then reply here so we know to look out for it.)


Hi Jeff,

Thank you for your reply.
The unsync problem is on a directory where every files that under that directory is unsync.

I have also send diagnostic just now

So the error message is implying that the “Pictures” subfolder itself is read-only.

Can you right-click on the “Pictures” folder in Windows Explorer and select Properties? There are a couple of things to check once the Properties dialog is up:

  1. In the General tab, at the bottom, uncheck the Read-only attribute. When you click on Apply, a Confirm Attributes Changes window may come up which will ask you to Apply changes to this folder, subfolders, and files. This is fine, so go ahead and select Ok to apply the change.
  2. In the Security tab, make sure your User has Read permissions. If not, edit the permission for your User and make sure you have Read access.

Once you’ve made these changes, please try to see if you can unsync the Backup folder again.

If that doesn’t solve the problem, then could you open a Command prompt and then run this command:

powershell -command "& {$the_file=\"$env:userprofile\odrive\PATH_TO_FILE_HERE\";Get-Acl \"$the_file\" | Format-List; dir \"$the_file\";}"

You can run the command by copying and pasting it into your command prompt window. You’ll need to change the text for “PATH_TO_FILE_HERE” to match your path to your corresponding \CloudDrive\SharePoint\SOME_HEBREW_CHARS\Backup\Pictures folder.

After running the command, please let us know what the output is.


I am the administrator on the computer. As I mention before, I did try to change the properties to remove the read only of the directory and the subdirectories and when the process finish the read only mark return.

I rename the Hebrew characters to English incase the problem cause by the non English characters.
I also change the path in your script because my odrive is not on the system profile drive.

the results of the script is:
Path : Microsoft.PowerShell.Core\FileSystem::D:\Local User Directory\odrive\CloudDrive\SharePoint\Revital\Backup
Owner : HH-DESKTOP\Hananel
Group : HH-DESKTOP\None
Access : HH-DESKTOP\Hananel Allow FullControl
NT AUTHORITY\Authenticated Users Allow Modify, Synchronize
BUILTIN\Administrators Allow FullControl
HH-DESKTOP\Hananel Allow FullControl
BUILTIN\Users Allow ReadAndExecute, Synchronize
Audit :
Sddl : O:S-1-5-21-3080020590-2098463196-1653741424-1002G:S-1-5-21-3080020590-2098463196-1653741424-513D:AI(A;OICINP;F

Directory: D:\Local User Directory\odrive\CloudDrive\SharePoint\Revital\Backup

Mode LastWriteTime Length Name

d-r— 1/14/2017 2:31 PM Documents
d-r— 1/14/2017 2:29 PM Pictures

Hi @hananel,
Since the read-only attributes are returning, it sounds as if there is another application that is setting those, for some reason. Is there anything else touching those folders, or the files inside, beside odrive?

Can you also tell me about the D: drive? Is that an internal drive or external?
The “Local User Directory” name is also interesting. Is there anything special about how that directory was created or its origin?

Additionally, can you describe your odrive use case? I noticed “Sharepoint” and “Backup” in the path, so I was wondering if one of your main use cases was backup.

The bottom line is that odrive will not be able to unsync those folder if they are read-only, since unsync involves replacing the local files with placeholder files.

Hi @Tony,
Thank you for your reply.

I found that the software that change the read only status is Odrive.

I uninstall Odrive from the computer, restart Windows and I can unmarked the read only property for the directory and the sub-directories under it, without any problem.
I install back the Odrive and the read-only property return.

One other thing, apparently, all my directories under odrive have read-only marked, and odrive dont have problem sync and unsync those directories.

Last thing, the directory in question, still not able to unsync.

Hi @hananel,
I cannot find an instance in our code where odrive will set a read-only attribute on a file or folder, so that is very strange behavior, indeed.

If you exit odrive, so it is not running, do you see the same behavior?

Would you be able to answer the questions I asked in my previous post?

My bad, the odrive don’t make the read-only attribute. for some reason its still exist and reappear after unmarking it. It also appear on other directortis and on other computers.
But, the read-only attribute seems not affect odrive to sync and unsunc other directories, so its seems that the read-only attribute is not related to the problem.

Sharepoint is between two computers and its backup files that I upload to one computer and hoped that it will upload to the other computer.

I solve the problem, by upload the files to other directory. quit odive, delete the read-only directory (without any issue) and its solve the problem

Hi @hananel,
It is hard to say why this was happening, but odrive was being prevented from deleting those folders for some reason.

Be careful with deleting them, because odrive will pick that up as a delete. You may want to recover them from the odrive trash so that they are restored as placeholders.