Files stuck in waiting from synced folder

My synced folder outside the main odrive folder always has 10 to 11 files that get stuck on waiting. Only after I restart or shut down my computer the files get synced.
All the previous posts about it are more than a year old.

Please let me know how I can solve this.

Thank you.

Hi @diego1,
The next time it happens can you send a diagnostic from the odrive menu so I can take a look at what might be happening and just let me know when it was sent?

Hi Tony,

Just sent the report. I have three files waiting at the moment that won’t sync.


Thanks @diego1,
These uploads are failing and then trying to resume, but Google isn’t providing the proper data to resume. It is definitely strange. I need to dig more into it and then see if I can get a test build to you to try out, but I may not be able to do that for a couple days.

So only a full computer restart fixes this issue?
If you just restart odrive, does it continue to hit the same error with the same files?

I’ve noticed that sometimes just quitting odrive helps but it’s not very often. It works better when I quit odrive, turn off the computer for a while (I’ve tried 30 minutes to overnight) and then try again and then at some point the sync catches on.

Yes, I’d be happy to try a test build.
I am working with a colleague in the same group of files and sometimes not knowing if we are in the latest version of the project is not very helpful.

Don’t know if it matters but they are Pro Tools session files and sometimes the new audio that was created. Most of the time are just the session files that are only ~20MB

Hi @diego1,
Thanks for the additional information. I haven’t forgotten about this.

I’ve just been doing some testing and trying to see where this can be improved. The error from Google is strange. I’ve never seen in happen in any of our testing. The behavior you describe is strange too in the sense that a system restart shouldn’t be different from an odrive restart (odrive doesn’t use any special drivers or anything lower-level for sync), so the result is the same in either case from an odrive perspective. Maybe something network-related is going on here…?

Hi @diego1,
Can you give this build a try? I am hoping it can provide a little more information in the diagnostic. It also has a couple of tweaks in it, although it may not help this current scenario:

If you reproduce the issue, please send over a diagnostic and let me know.

Hi Tony,

I’ll give it a try. Maybe you are right that something is messing with my network. I’ve been looking at the apps I have running in the background and two of them are suspect of doing something to odrive: Freedom and Bitdefender. I don’t know how I can test that but I’ve noticed less errors if I stop them. I’ll install the new build to see if it helps and send the diagnostics if I get stuck again.


1 Like

Thanks @diego1!

Please let me know when/if you are able to reproduce the issue.

Hi Tony,

Just sent a report. I’m pretty sure Freedom is doing something to my network besides blocking distracting websites. After I quit the program, the waiting files started to upload. I sent a second report after quitting the program, maybe you can see what is wrong.
I will have to contact their support team to see if they can find a fix.

Thanks for your help,

Thanks @diego1,
The diagnostic was able to provide a little bit more information. An SSL protocol error is being encountered. This causes odrive to resume the upload, but then Google returns the unusual error we are seeing. It may be because the upload connection was aborted in a strange way.

I’m not sure what Freedom does with the connection, but it sounds like it may be in the middle somewhere and causing some instability. Is there any way to whitelist odrive or prevent it from trying to interact with it?

Hi Tony, I’ve been watching the odrive sync and seems to be working now that I whitelisted it from Freedom. I ende up whitelisting and to be safe.
It’s very odd since I thought I was only blocking three or four distracting websites instead of apps or the whole internet.

Thank you for your help figuring out this issue.

1 Like

Great! Thanks for keeping us updated @diego1 . This information will help others who run into this.