Files getting removed when opening a placeholder folder


I have a really annoying issue here. I have some folder that I “unsynced” a couple of months ago, and if I try to open them now, all the files inside are getting wiped out.
If I open those folders on Amazon Cloud Drive directly, I see all my files. Then I open them on my Windows computer, it shows them empty. I re-open them in Amazon Cloud Drive and now they are gone.
I looked the the trash on Amazon or odrive, and none of them show the files.

I tried creating a new folder and reproducing, but it doesn’t present the issue.
As it might be difficult to reproduce, you can contact me if you want to see a reproduction or if you need more information. As a developer myself I understand how difficult it is to solve an issue without reproduction steps.
Also, if you think my files can be recovered, that would be great… I have a copy of them but it’s always nice to not have to re-upload a few gigs.


Yes this is very strange indeed. What is especially strange is that the files are disappearing completely instead of being put into the Amazon Drive trash. That leads me to believe that something might be happening on the Amazon side of things.

Can you repro this again and send a diagnostic from the odrive tray menu along with the name of the folder? I can take a look and see if there is anything we can identify from our side.

Does the same phenomenon happen if you navigate to that location in the odrive web client? ( ).

I tried with the web client with some folders just beside the ones I tried yesterday and it worked without any issue. Also tried with with the desktop client on some other folders (I just ran out of folders to try) and it worked without any issue.

I still sent a diagnostic in case your stack trace allows you to go back to yesterday at around 10PM CST. Please let me know if you find anything, I’m kind of scared to open any folder.

Also if the issue happens again, I will send a diagnostic right away and either comment here or open a new topic.


Can you tell me the name of an example folder where this was happening? The diagnostics go back far enough to see odrive processing files that had been removed in the cloud, but I want to make sure I am looking at the right thing.

All of them were called “RAW” (the ones that worked yesterday, and the ones that didn’t work 2 days ago.
For example the first “RAW” folder that got its content removed 2 days ago was itself in the folder named “05.07”. So in one word, “05.07/RAW”

Thanks. I see those files reported as “missing” from Amazon Drive while we were asking for the contents of the folder. It is all very strange. To odrive it looks like the files have been removed in the cloud somehow.

You cannot find those files in the Amazon trash either?

They are really not in the trash, I just checked one more time and the last deleted file is from months ago…

Oh and just in case it has any kind of importance, last week I applied the latest Windows 10 update (the “one year anniversary” one), and I think I didn’t try using odrive until I had this issue.

Thanks for the additional details.

This is a case I have never seen before. odrive actually can’t permanently delete anything in Amazon Drive (Amazon doesn’t even offer an API to permanently delete things out of their trash). Anything that is deleted, regardless of what client is used, should be put into their trash.

If the files are not in the trash the only thing I can think of is that they were moved/renamed somehow, which put them in a different location. I believe you searched for the files using the Amazon Drive search and still were not able to find them though, correct?

Have you tried contacting Amazon about this yet?

I did not try the search until now, and it didn’t find any other file than the new copy I re-uploaded after that happened.

I haven’t contacted Amazon about it, as I thought the issue was coming from the client (due to their web client working fine). I can try to ask them, could you tell me which endpoint reported the files as missing? And any information you think could be useful for helping them to figure out?
Else if you prefer to ask them yourself, I can provide you with my account name or any information you might need…


If by endpoint you mean which API endpoint, it was a “children” request on the parent node. That request returned the list without the RAW folder, indicating that it no longer existed in that location.

If you want to reach out to them, you can copy me on the e-mail (tony at odrive) so I can assist, if needed. I would definitely like to know what the root cause of this behavior is.

Yes I meant API endpoint. Oh so it was the folder itself that was missing? I thought it was all the files inside the folder, because I was opening the RAW folder itself, not RAW’s parent.

I looked and it seems that the best place to ask a question about the cloud drive API is the AWS support:

I don’t have an account to get such support, so would you be able to ask them the question?
Else I saw that I could ask a question on the amazon developer forum :
But it doesn’t seem that there is any sections for the drive API so not sure this is the best place…?

Hi @cleman,
I think you may be right, that it was the files inside the folder that were reported as gone, not the folder itself.

In any case, the API seemed to be reporting things correctly since you verified that the files were actually gone, when looking on the web. The question we want to ask Amazon is where the files went. You should be able to reach out to their support staff to start, and then we can go from there:

If you choose to communicate over e-mail you can cc me on the chain.


I’m really sorry I haven’t answer in so much time. I actually let it slip for a little while and just got the issue again today. I just sent an email to Amazon’s customer service, I included a lot of details, along with the link toward this thread, and your contact. This time it happened without use of the odrive client, so the issue is definitely coming from their side, but I’m sure you would like to know the resolution of this bug anyway…
Will keep updating this thread.

Thanks for update @cleman. I would definitely like to know what you find out.