Files deleted on source stuck in waiting on Ubuntu client

Hi odrive team,

I’m using odrive CLI to access OneDrive on Ubuntu. Everything works great using the scripts provided in the forum (thanks!), except one issue:
I have all folders and files synced on the client. When I delete a file on another computer (or OneDrive web interface), it does not get deleted on the Ubuntu client. Instead in ends up in the waiting queue. When I do status --waiting it it returns path-to-file - Error accessing file.

To solve the problem I can unsync the file which returns the placeholder. The placeholder then immediately gets deleted. This “solution” is however not permanent as I would have to unsync and resync all my files on the client to detect any deleted files. This can lead to conflicts if I’m currently editing a file which is being unsynced. Do you have a solution to this problem?

Thanks a lot for your great work!

Hi @henrik,
This was an issue a while ago, but it was resolved in a later version. Do remember how long ago you downloaded the agent? Can you double-check that the latest version has the issue?

Hi Tony,

thanks a lot for your reply. I just followed the link you provided to reinstall sync agent. To do so I chose the command for 64-bit Linux:
od="$HOME/.odrive-agent/bin" && curl -L “” --create-dirs -o “$od/” && curl -L “” | tar -xvzf- -C “$od/” && curl -L “” | tar -xvzf- -C “$od/”

After reboot of my system and restarting the newly installed agent, I still see the same problem. The version in status shows prod 916. Is this the latest version? Below is the complete output from status (I now have 2 files waiting as I tried to delete another file).

Thanks, Henrik

#output from status
isActivated: True hasSession: True
email: accountType: OneDriveForBusiness
syncEnabled: True version: prod 916
placeholderThreshold: neverDownload autoUnsyncThreshold: never
downloadThrottlingThreshold: unlimited uploadThrottlingThreshold: normal
autoTrashThreshold: never Mounts: 1
xlThreshold: never Backups: 0

Sync Requests: 0
Background Requests: 0
Uploads: 0
Downloads: 0
Trash: 0
Waiting: 2
Not Allowed: 0

Hi, sorry. I didn’t answer your reply completely. I actually installed the agent yesterday for the first time following the same link that you provided earlier. Thanks, Henrik

Thanks @henrik. It looks like you are on the latest, so we will need to dig into this.

Hi @henrik,

I have been investigating the causes of the error you are seeing in removing files from your local machine. It seems like sync is correctly picking up the remote delete (from another machine or OneDrive web interface) but hitting permissions error at OS level each time odrive agent try to proceed with delete operation.

Is there a possibility that file(s) is/are open into another native application or monitored by another process?,

File open into a native app: gave me similar error during my testing.
/home/asifubuntu14x64/Documents/odrivemount/OneDrive For Business/Lighthouse.jpg - Error accessing file

If so please close the file(s) and see if it correctly picks up the remote delete?


Hi Asif,

Thanks for investigating this issue further. I have checked any issues with file accessibility:

  • shut down all Laptop’s with access to OneDrive
  • rebooted my Ubuntu PC
  • opened terminal
  • ran odriveagent and a refresh on the folder
    I also tried to reboot straight to command line, but unfortunately I still see exactly the same problem as described above.

There should also be no issue regarding ownership as I can reproduce the problem by copying a file in Ubuntu, going to the web interface to delete it and then wait for the status to change to “waiting”.

I’m running Ubuntu 16.04 LTS 64-bit. I hope you have any ideas on how to look into this issue further.


I can reproduce this on ubuntu 16.04, I haven’t seen this error before, so it may be something new for 16.04. I will make sure by trying on 14.04 to see if there is a difference. If so it will at least give me some clues at what to look for.

Update: works fine on 14.04, so its something new… still looking

Hi Tony, I’m glad you were able to reproduce the problem. Let me know if I can help with anything to track the problem. Henrik

I’m still working through this one and should have an update next week.

Hi, I have this problem on my Ubuntu 16.04 machine too, are there any update about this issue?

Apologies for the delay on this one. It is still outstanding, but I think we should have something to fix it this week.

1 Like

Here is a beta version to test. Can the folks that are seeing this please test and let me know if it fixes the issue?

Can I have a 32-bit version of the agent?

@kjiec4 here is the 32bit version:

Well, all the files, I’ve deleted long time ago from ACD, are deleted from local folder now.
Deletions, that have been made after an odriveagent binary update, are synchronized too.
Thanks for the fix!

1 Like

@Tony, Everything works great also for 64bit. I’ve tested deleting, adding, renaming of files and folders on Ubuntu 16.04, Windows 7 and online. It all synced fine. Thank you for the extensive effort!

1 Like

It works :slight_smile:
Thank you very much for the update!

1 Like

Thanks for the feedback everyone. We will push this version out on our download pages so everyone can get it.

1 Like